Guest's picture


Just downloaded the latest Turnkey Wordpress appliance, did initial setup and wrote some test posts. At uploading media it stopped - Error saving media attachments.

I've gone through the forum and Google looking for answers, so I've set the owner of the upload folder (which didn't exist so I had to make it) to www-data and permissions to 777. Still no go.

I then made a wptmp-directory and enabled temp folder for uploads in Webmin, and discovered that even though it returns no error it hasn't made any changes to php.ini. Went in and edited it myself, setting the temp folder to "/wptmp/".

Still no go.

I'm also unable to search and download themes, but I haven't checked that. The box pings internet sites without problems, so it's connected. Permissions here too?

Has anyone experienced the same problems and found a solution?


Thanks in advance,


Jeremy Davis's picture

However others have noted previously that TKL WP file permissions are probably a little restrictive OOTB. In testing (to help others overcome issues updating) I changed ownership of the whole /var/www/wordpress folder heirarchy and that seemed to resolve all the permissions issues that I had encountered. I'm not sure if that will resolve your woes, but worth a shot I guess...

In other words:

chown -R www-data:www-data /var/www/wordpress

It's possibly not best practice to give the webserver full ownership of the whole shooting match but from a practicality perspective it certainly worked for me! :)

Add new comment