Bruce Button's picture

I have installed Turnkey Linux on a dedicated server machine. The installation is standard based on Debian Wheezy (i.e. the latest version). My main purpose is to use the machine as a development server for Joomla. However, I have a very strange problem with most Joomla installations. Although the sample version 3 installation from the Joomla site works ok, a number of other installations don't.

Behaviour is as follows: I can access the back end (administrator area) and all settings are visible; content (articles, etc.) appears and can be edited. No errors are given when saving changes. However, when I try to open the site (front end) I get a blank screen, or one with just the name of the template.

The strange thing is, when I copy the files and database from the Lamp server to a Wamp server, the site displays normally. (The entire site is transferred to the Wamp server without making any changes either to the database or to the files. Database transferred by exporting and importing through phpmyadmin.)


The behaviour is the same for templates from two different template suppliers. I installed the sample data in all cases.

Before running the Joomla setup, I changed the ownership of all files and directories to www-data:www-data. I changed directory and file permissions to 755 (I also tried 755 for directories and 644 for files).

I have tried to keep the installation as standard as possible.

Although I know Windows well, I am new to Linux. I can't figure out if its an issue of permissions, of settings for apache/php/mysql or what. It's a mystery, but very frustrating!

Any help will be much appreciated! Thanks!



Update: Wed 15 Jan

I have solved the problem - by installing a gd library for php. Hope this can help others with the same problem. Perhaps TKL can consider adding that library to the standard TKL appliance.




Jeremy Davis's picture

Just to clarify this issue was with the v13.0 Joomla appliance - is that correct?

Thanks for posting your workaround. I assume that it was the php5-gd package that you installed?

Assuming that I am correct in my assumptions, I agree that it should be included. As soon as I have confirmation from you I will lodge a 'feature request' for it to be included in future releases...

Bruce Button's picture

The name of the file that I downloaded is 'turnkey-lamp-13.0-wheezy-amd64.iso'.

Maybe I should have used the Joomla appliance. I didn't because I am accustomed to installing Joomla sites directly into a Wamp stack or onto a web server. Perhaps the gd library is already present in the Joomla appliance.

Anyway, it was the php5-gd package.

So maybe include this package in the Lamp appliance as well as the Joomla one (and any others that may have need for it - Wordpress perhaps?).


Add new comment