L. Arnold's picture

From the GitHub documentation I am hung pretty early.  Using I386 for architecture:

ARCH=$(dpkg --print-architecture)
CODENAME=$(lsb_release -s -c)

cd /turnkey/fab/bootstraps
wget $SOURCEFORGE/bootstrap/bootstrap-$CODENAME-$ARCH.tar.gz

If I follow the instructions, I assume I need to be in "/" root entering the first ARCH, CODENAME and SOURCEFORGE variable declarations.

This time I get awaiting response... 302 found

connected......  bootstrap-wheezy-i386.tar.gz

HTTP request sent, awaiting response...

nothing seems to show after that.  I just get "retrying.  reset,  connected, awaiting response..."

Is ther an I386 bootstrap to actually pull?  Do I need to get some keys set with sourceforge?  Should I simply be more patient?

I have a Joomla 3.2 that I am trying to build.  If goes well want to try an OpenERP App also.

L. Arnold's picture

Good trick is to enter

ARCH=$(dpkg --print-architecture)
echo $ARCH
CODENAME=$(lsb_release -s -c)
echo SOURCEFORGE="http://downloads.sourceforge.net/project/turnkeylinux"


echo $SOURCEFORGE  (had to add "echo" to get variables to confirm/display on restart and re declare - )

verifying that a variable was taken into memory.

Moving to .sig next.  Will see how we proceed.  (Awaiting response... again"

Just added .sig to the previous command as in.. 

wget $SOURCEFORGE/bootstrap/bootstrap-$CODENAME-$ARCH.tar.gz
wget $SOURCEFORGE/bootstrap/bootstrap-$CODENAME-$ARCH.tar.gz.sig

Typing the full secondline worked while adding.sig didn't for some reason.


..  worked through the cdroots.git and common.git  so I guess the fun starts next.


Jeremy Davis's picture

I have only run TKLDev on x64 and haven't had any of your dramas so haven't had anything to offer...

Sounds like you're having progress though... Good luck :)

Add new comment