Hi!
According http://php.net/supported-versions.php our LAMP 15 php 7.0 will be out of support in less than in 2 weeks.
Looks like Debian 9 has no intention to upgrade php to higher versions (i hope i am wrong).

Is there any plan from Turnkey to upgrade? Or maybe you know something more from Debian? Or we shall do it manually? If so, did anyone made upgrade already in LAMP 15?

Thank you.

Forum: 
Jeremy Davis's picture

That is "upstream" support, so yes, PHP themselves will no longer be providing updates for PHP7.0. But that doesn't mean that it won't be supported. TurnKey doesn't install PHP7.0 direct from PHP, we use the Debian packages, so that "EOL" doesn't really apply.

The Debian security team will be providing backported security updates for PHP7.0 for one year after the next Debian release (10/Buster) becomes stable (and 9/Stretch becomes "oldstable") - almost certainly some time in 2020. So we have at least another year of "Security Team" support. Even after that, Debian support will continue. Once the "Security team support" finishes, the responsibility of maintenance of PHP7.0 on Debian 9/Stretch will move to the the LTS team and support will continue until June 2022.

FWIW whilst this may seem a little strange if you are coming from a Windows environment, it is quite common in the Linux world. It is one of the awesome benefits of opensource, anyone can maintain it if they wish! And having specific versions maintained for extended period of time is one of the many reasons that Linux is known to be so stable and such a great choice for a server. So Debian won't be working alone on maintaining the security updates. They will be working with other teams from other distros such as Ubuntu (16.04 also includes PHP7.0 and will be supported until 2021) and others such as SUSE and Red Hat, etc.

Having said all that, we do have plans to support users to select alternate versions of PHP (namely 7.2) on TurnKey v15.x at some point in the future. Although they won't be official Debian packages, so won't have automated security updates. If you're interested in that, then please let me know and I'm happy to share my recommendations on how to do that manually (when we do provide it, it will be "TurnKey"! :)

Thanks! Yes, i am commoving from “windows”, hence this questions was. Clear to me now. For now will stay with 7.0 :)

Add new comment