Zach's picture

Hi guys,


I can't get to webmin on port 12321 for our turnkey install, I'm running turnkey-lamp-14.2-jessie-amd64

netstat -lp --inet gives me the the attached results (only close thing I can see is localhost:webmin and localhost:12319

I've Googled as best I can and tried a few fixes such as stopping and starting the webmin service but to no avail.

Any ideas?


EDIT: Success! Thanks Jeremy for the fix, the issue here for anyone who stumbles across this thread was stunnel4 service wasn't running so it was just listening on localhost for port 12321. Doing 'service stunnel4 restart' and the same for Webmin.


Zach's picture


Didn't attach image, good start!

Jeremy Davis's picture

I wonder why you couldn't see them? FWIW, I also checked after logging out. (I thought perhaps because of my "admin" user only I could see them?) But I could still see them. Weird...

Zach's picture

Ugh can't attach an image, here's the results of netstat -lp --inet


root@proxy /# netstat -lp --inet
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost:mysql         *:*                     LISTEN      1169/mysqld
tcp        0      0 localhost:webmin        *:*                     LISTEN      4107/perl
tcp        0      0 *:http-alt              *:*                     LISTEN      626/nginx -g daemon
tcp        0      0 *:ssh                   *:*                     LISTEN      592/sshd
tcp        0      0 localhost:smtp          *:*                     LISTEN      1417/master
tcp        0      0 *:36602                 *:*                     LISTEN      638/xinetd
tcp        0      0 localhost:12319         *:*                     LISTEN      616/shellinaboxd
udp        0      0 *:snmp                  *:*                                 609/snmpd
udp        0      0 *:10000                 *:*                                 4107/perl
roller24's picture

I always use the local ip, have you tried that?


roller24's picture

Web - point your browser at either:

  1. - not encrypted so no browser warning
  2. - encrypted with self-signed SSL certificate
Jeremy Davis's picture

FWIW in v14.x & v15.x by default Webmin (and Webshell aka shellinabox) is running behind stunnel. So whilst it appears that Webmin is running, by default it is only listening to localhost (as your netstat output shows).

So I suspect that the "fix" is to ensure that stunnel is running (and start/restart it if it's not):

service stunnel4 status

If that reports it's status as anything but "active (running)" then it's most likely crashed, or not running for some other reason. Start it like this:

service stunnel4 start

Or if it reports "active (exited)" then restart it by replacing "start" in the command above with "restart" (alternatively you can cycle "stop", then "start").

Hope that helps.

roller24's picture

I misinterperated Zach's post, I thought he was trying to call webmin with a url of localhost:12321, which would open only in certain environments. I run my turnkey on a device existing remotely from the machine on which I access the webmin ui . A localhost url would only look on my machine and not a remote machine on a separate piece of hardware. 

I'm unsure how that would equate in a virtual environment existing on the same machine as the visitor's web browser being utilized to  access it.



Jeremy Davis's picture

FWIW, I learned the basics of what I know of Linux in general and TurnKey in particular by trying to help people out on the forums, so you're in good company! :) I helped a lot of people out, but I missed the mark plenty of times...

Also, perhaps it was me that misinterpreted the issue?! (I don't think so, but it's happened plenty of times before, and certainly won't be the last).

And even if it wasn't relevant on this occasion, your posts here may well assist someone else who is making the mistake that you thought this was, finds this thread and reads your answer and gets headed in the right direction!

So it is not a problem at all. I more than welcome anyone who wants to help out. Thanks again! :)

Zach's picture

Hey guys, thanks for the help, I'll give it all a go this morning but it makes sense that it's just looking at localhost, I'll get stunnel running and hopefully wellwbe all good, thanks everyone!

Zach's picture

Awesome, I'm in! Had to restart webmin and stunnel4 and suddenly everything was good in the world, thanks for all the help guys, much appreciated!

Andrew Birch's picture

I could load webmin with any issues.  The VM is local on my network and I can get to the WordPress Site, the WordPress Shell and Adminer.  So ports 12320, 12322 loads fine, but port 12321 no longer does, it did when I first set up the VM.




Jeremy Davis's picture

Is the stunnel service running? Is the Webmin service running? (See posts above with instructions on how to check).

If not, what happens when you restart these services?!

Add new comment