Are the appliances affected by AWS image upgrade deprecating PHP5?

Jason van Wyngaard's picture

Hi

I saw recently that Amazon had updated its images to PHP7. The server I'm using has PHP5. I want to know if I have a snapshot and the server fails and I use the snapshot on the new server, will it be an exact copy with PHP5 or must I upgrade the PHP code?

I'm using lamp-13.0-wheezy-amd64.

Jeremy Davis's picture

I was sure that I'd already answered this question earlier today. I had a bit of a look and indeed I did, but I hadn't sent it! Doh! Sorry about that... Anyway, thanks for posting here and here's what I wrote:

v13.0 is a previous major release and we can only give "best effort" support for that. Having said that, the underlaying OS, is supported by the Debian LTS with security updates until 31 May 2018. Assuming you haven't disabled auto security updates enabled, then you should currently have PHP5.4 (5.4.45 to be precise).

Our current images (v14.2 is almost complete) provide PHP5.6 (5.6.30). We do plan to ship newer images that provide PHP7 within the next month or 2 but no clear ETA just yet.

We no longer have v13.x images, so already we can't provide the exact image that you are currently using.

If you have a server snapshot of your current server, then it should be a complete snapshot of your OS, so everything should be there and it all should "just work". Please keep in mind though, generally to ensure data integrity you should stop your server before you perform a snapshot. Often snapshots of a running server will be ok, but they can't be relied on (data corruption can happen if a file is being copied at the same time it is being written to) so that's not really good enough for a backup!

TKLBAM (our backup and migration tool) should allow you to migrate your backup to a new server relatively easily. Although you will still need to make some manual tweaks. Also if you rely on the current PHP version you have, you will need to install an older version of PHP. It's not ideal and will potentially be something of a security hole, but the only way to avoid that would be to upgrade to a newer version.

If you can cope with PHP5.6 then I'd suggest upgrading to v14.x would be a good idea as then you'll get security updates until 2020.

Jason van Wyngaard's picture

Hi Jeremy

 

Thanks for the feedback. Discussing with my dev and will decide on a way forward.

 

Kind regards

Jason

Jeremy Davis's picture

If you'd like to have a go at using TKLBAM to migrate, then we have a doc page that provides a recommended workflow, plus covers some specific issues you may experience and the required workarounds. It's not exhaustive, but should help.

If you (or your dev) have more questions, I'm more than happy to help you out as best I can.

Post new comment