Witzker's picture

Hi

here: Updates | TurnKey GNU/Linux (turnkeylinux.org)

I found That there is still not actual (21.05.22) version 24 Implemented.

When will it be possible to expect the actual version of Nextcloud based on your 17.0?

What do you think?

THX for info

Forum: 
badco's picture

There is an install script that works well in a LXC that you could migrate too.

https://docs.nextcloud.com/server/latest/admin_manual/installation/sourc...

 

Otherwise you will have to the dev work to upgrade the appliance.

Jeremy Davis's picture

We hope to release a Nextcloud v17.x update ASAP (FWIW it will be v17.1). The holdup is because we've discovered an issue where a password set by the inithooks isn't honored by Nextcloud. That is because Nextcloud has it's own password checking mechanism and if the password you set is not compatible, it just silently fails.

We have a plan to work around that, but it means it's delayed because we have so much on right now and are trying to carefully prioritise our efforts.

Stefan's picture

Thanks four your guy's efforts!

I hope nextcloud gets updated soon :)

Stefan's picture

I've tried updating the 16 container to debian 11, but unfortunately it breaks the whole thing.

I got a bunch of systemd related errors while apt was updateing and afterwards the container just shows a blank screen...

 

Here is a patebin of the upgrade process:

https://pastebin.com/7baj9Xec

Jeremy Davis's picture

From a glance, the main thing that stands out to me from your logs are a number of systemd related messages saying "Transport endpoint is not connected". I hadn't come across that error before, but google suggests that it's likely an LXFS (if you're using LXC container - which I guess you are?) and/or filesystem mount issue. I also read error reports mentioning DBus, but we don't install DBus by default, so I'm fairly sure that's not the issue. FWIW of the 3 services it notes together, only 'systemd-journald.service' is one that should matter on TurnKey. But it also gives a similar error/warning later when attempting to process the MySQL/MariaDB upgrade (trying to stop the service; again "Transport endpoint is not connected").

So my guess is that there is/was some other issue with your server (or perhaps the issue is on the host?) and that this breakage is a result of that. I suggest trying to restart your container and see how that goes. Otherwise, perhaps also try restarting your host too?

If you get there and things seem ok (Nextcloud almost certainly will still be broken because of MySQL/MariaDB state) then I'd try re-installing MariaDB (i.e. 'apt update && apt install -y --reinstall default-mysql-server').

If that doesn't work, hopefully you have a backup of your appliance from pre-upgrade? Assuming so, then I'd try restoring your backup and trying the whole process again.

Stefan's picture

It's an LXC Container running on Proxmox VE 7, literally just pulled the image, started it, setup nextcloud and then did the apt dist-upgrade, so no data lost, it was a test container ;)

 

I did restart the container after the upgrade and it just goes to a blank screen, no output at all, so I'm aussming something major broke there.

Add new comment