Dear community

For some Imagepresentations i like to get an easy to use, ultramobile, Lamp- Mini Server thats why i found Turnkey the perfect solution for my topic. The ISO Live CD works well on my old IBM Laptop. No Problem a all, but thats the problem i can't install on die Via Epic Board. Install. stops at

[55.303681] VFS: Cannot open root divice <NULL> or unknown-block (104.1)

[55.303681]Please append a correct "root=" boot option; here art the avalible partitions:

[55.303888] Kernel panic- not syncing: VSF: Unable to mount root fs on unknown-block(104,1)

What could I do? Or is the i686 CPU not supported? Any help would be apprichiated as Knoppix 6.1 or WinXP S3 have been working with same Bios Setup etc. 

Jeremy Davis's picture

You may need to select some alternative options (f4/f6) on the first/install/boot screen (you know the one that first comes up that has the TKL logo and has the option to run live, install etc.)

I have had a similar (but probably unrelated) problem with another linux distro that i installed a few years ago. The live CD worked fine but I would get a kernel panic when trying to install. Sorry I have no idea what options I ended up using (even if I could remember they may not be relevant to you anyway). I suggest you explore the different options available (I assume that these would be standard Ubuntu install options) and/or use a bit of trial an error.

bulek's picture


I'm experiencing same problem with both my VIA EPIAs mobos. Ubuntu server, Knoppix works on them. I even cannot see boot screen of turnkey linux (only boot: prompt appears), so I cannot play much with options.

Any options recomendable that could be tried from boot: prompt ?

Thanks in advance,


Jeremy Davis's picture

Pity Michel never got back to let us know how he went and whether and/or how he solved the issue.

When you say that Ubuntu server worked I assume that was the alternate installer? (AFAIK TKL is based on the i386 Ubuntu install medium so if that works then so should TKL).

If we can get Alon or Liraz (the TKL Devs) to help out, there may be some way installing Ubuntu 8.04 JEOS and then add TKL on top of it (skipping the initial problematic install steps of TKL). Although I'm not even sure if that'd be possible.

Ian Goddard's picture

I've loaded TKL Core on a VBox virtual machine on an Epia Via C3 motherboard using Ubuntu 8.04 server as the host and that ran OK.  This suggests that the instruction set (not a full i686) isn't a problem.  As the OP's problem seemed to occur with installing on the bare metal is it possible that the TKL build doesn't include drivers for Via H/W?

Liraz Siri's picture

We publish all the source code for our custom packages and also operate a repository anyone is free to use. However, a TurnKey appliance is more than its components. The magic is in the integration details (e.g., configuring cron-apt to auto-install security patches), and there is currently no way to encapsulate that in a package. It's embedded directly into the appliance.

OTOH, we're using standard Ubuntu components (e.g., kernel, bootloader) so I believe most issues with hardware can be sorted out with a workaround (e.g., bootloader cheatcode) that's probably just a Google search or two away.

Liraz Siri's picture

Note that in April 2010 a new Ubuntu LTS will come out and a new release of TurnKey will follow with a new kernel in which this bug was probably fixed.

Ian Goddard's picture

...having read that page I'm wondering how one of my boxes is running.  This is an Epia board running a Samuel 3 processor with the following flags: fpu de tsc msr cx8 mtrr pge mmx 3dnow up.  It's running 8.04 from the server CD and has previously run 8.04 Xubuntu.

I know the previous LTS server version, 6.06, did have problems with these cpus.  In that case it seemed to be the missing cmov that was critical (Red Hat derivatives compiled with i686 kernels and OpenSolaris also had problems).  However the "server" option on the standard CD installed an i386 command line system & that seemed OK.

I have another Epia board running a VIA Nehemia also under 8.04 (Xubuntu) i686  with the following flags: fpu de pse tsc msr cx8 mtrr pge cmov mmx fxsr sse up rng rng_en.  A couple of versions of OpenSolaris seemed OK on this board from the CPU point of view but they didn't include the full set of Via drivers.

I've also had a VIA powered thin client running 6.06 & 8.04 with no problems.

The root problem here seems to be a lot of variation between VIA processors.  I've come across at least one independent web-site cataloguing the variations as they'd found them but last time I looked at Via's own forums a request for a definitive list from Via themselves got nowhere.


Liraz Siri's picture

TurnKey's ISO build uses the regular Ubuntu kernel. Ubuntu server uses a different kernel optimized for server hardware. We had some issues with it on some of the virtualization platforms we tried so we decided to go with the default kernel instead.

Maybe that might explains why Ubuntu server would work when TurnKey doesn't.

Add new comment