Almost Over.

base : Turnkey core lucid

Currently i have some problem with phpmyadmin on port 12322

If someone is able to find the mistake , please help me .


Now every problem is solved ........



PHPMyadmin - https://<ip>:12322


If LAMP for lucid is ready , i can use it as base for other appliances :)

Jeremy Davis's picture

That's nice. Now anyone who wishes to base appliances on Lucid Core can nest this patch in their LAMP based patch. The beauty of this is if TKL devs tweak the official TKL LAMP it shouldn't matter and they don't have to pull apart a patch that includes LAMP stuff as well as something else! Good work Basil.

[update] I've just tried patching Lucid Core with your patch and a couple of issues (not big ones though):
  • Firstly I don't think TKLPatch liked the patch in .zip format:
extracting patch to /tmp/tmp.hOuTvioEHq
gzip: stdin has more than one entry--rest ignored
tar: Child returned status 2
tar: Exiting with failure status due to previous errors

I repackaged it as .tar.gz and it started fine.

  • The patch is erroring out for me (just one file though):
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Does your patch use file(s) not within the repos that are enabled in TKL by default? I'll have a bit more of a look...

[update again] Turns out my error was caused by a corrupted file on my local Lucid mirror (I use a custom sources.list, same as default, but includes my local Ubuntu mirror listed higher than the default Ubuntu repo). I reverted to default Ubuntu repos and patch completed fine. There were some warnings but obviously not critical:

apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName
[Thu Aug 12 15:23:44 2010] [warn] NameVirtualHost *:80 has no VirtualHosts

Obviously not show stoppers and I'm sure for my purposes it'll be fine.

I just downloaded the zip file and extracted it ... here i 'm having no problem with the zip format .

Also i didn't used anything outside the repo .

As far as i know , the apt-get in lucid-core having some problem , sometimes it works , sometimes it won't.

just try one more time . i 'm sure , it will work.

The error may caused because of an invalid entry in resolv.conf

JedMeister , a new archive added .Please check that

Jeremy Davis's picture

Not sure whats happening with the zip, wonder why it works for you and not me? I'm doing all this within TKL Core Lucid with only an 'apt-get upgrade' and tklpatch installed. I only tried once and then repackaged as .tar.gz and it worked ok.

In case you missed my edited post above, it was a corrupted file on my mirror that was the problem.

I'll try to have a look tomorrow. Its very late now here and I have to go to sleep...

Goodnight ZZzzz...

I'll update the patch tommorow ,and will  upload it here ........


JedMeister , Thanks for checking !

Jeremy Davis's picture

Basil, from your post above:

I just downloaded the zip file and extracted it ... here i 'm having no problem with the zip format .

So you are extracting first? Then patching using the extracted patch? I reckon thats it then. If its in .tar.gz format you can use it as it is (no need to extract the patch first). Just like this:

tklpatch-apply tkl.iso patch.tar.gz

Could that be it do you think?

[update] Oops, I just noticed that you've removed the zip so I guess thats irrelevant now. I'll test shortly and report back.

so tar.gz  can be used for patching iso ?? that i didn't know.

What i mean is that , just extract the zip or tarball and run it as

tklpatch turnkey.iso LAMP_Patch_folder

Jeremy Davis's picture

Its all clear now. So your .zip patches probably would've worked fine, but I think having them packaged as .tar.gz is preferable and removes a step, so that's got to be good!

Thanks for uploading a new patch. Sorry I haven't had a chance to test it yet. I'll hopefully get to it in the next few days. I'm still a bit of a newb but I'll have a look at the phpMyAdmin issue too (although don't hold your breath).

PS I hope you don''t mind I edited some of your posts to take out extra line breaks (& fixed a minor typo).

The problem with phpmyadmin is solved , now everything is fine.

Jeremy Davis's picture

If I click on the LAMP.tar.gz link above it just opens in my browser as gibberish. (The address is

Instead, if I 'Save as...' it defaults to saving a file called LAMP.tar_1.gz (as the address above would suggest.
If I 'Extract here' (using default Ubuntu Lucid 'right-click') I get a new file called LAMP.tar_1
If I open that in Archive Manager (File Roller 2.30) I can see a 30kb file/folder called LAMP but if I try to extract it I get "An error occurred while extracting files."
I also tried 'Save as...' and renamed the file to LAMP.tar.gz but it won't even open. I just get:
tar: This does not look like a tar archive
tar: Skipping to next header
tar: Exiting with failure status due to previous errors
Can you please try uploading again please? If a zip is easier, that's ok. Cheers

Reuploaded !!

Jeremy Davis's picture

Thanks Basil. Looks good. I just donwloaded and it saved and opened fine. I haven't actually fully tested it yet but will do a bit later.

Cristineta's picture

I'm a newbie on TurnkeyLinux. I know how to download and use the appliances, with the VMware player.

But I don't know how to install the patches, like this one for LAMP on Lucid.

I didn't find the explanation in the help or forums, so please, can you tell me how to use this patch on a base appliance or show me where are the instructions to do it.

PS: I'm using it on Windows.

Thanks you very much.

First of all , this is not the right thread to ask


Download the VMDK image of any appliance and open it with vmware player.


Or download the ISO file and install it as a virtual machine on VMware/VirtualBox

Jeremy Davis's picture

Unless your problems relate specifically to this patch (which is sounds like it doesn't), you'd be better starting your own thread, probably in the support area.

Secondly, if you're newbie, unless you have a specific need to use a Lucid based LAMP stack then you would probably be better off using the current stable TKL LAMP release. It's secure, works well and requires no additional steps beyond install (such as installing patches). IMO unless you are keen to learn more about TKL and/or help with beta testing there are only 2 valid reasons for using the TKL Lucid Core beta with Basil's LAMP patch. 1) Hardware support (which doesn't apply to you seeing as you're using a virtual environment); or 2) You need to later version of Apache, MySQL and/or php than what's included in TKL LAMP stable.

Third and final point; not sure where you looked but a search (box in top right corner) for "install tklpatch" or "apply tklpatch" turns up quite a few links that would head you in the right direction. Or navigating to Help>>Community Documentation>>TKLPatch - a simple appliance customization mechanism would've done the trick too! But to make it even easier, have a look at this post I wrote yesterday.

Good luck, any further questions or points that need clarification, please don't hesitate to ask (but perhaps either on that other thread I posted or start your own).

Cristineta's picture

First of all, sorry for the delay answering and thanks for your help.

I didn't find the right documentation because I was no searching the right terms, thanks again.

I need Lucid Lamp to use this appliance (OrangeHRM):

So I installed the Lucid appliance using the iso and now I'm trying to apply this patch, to have the LAMP installed and then apply the OrangeHRM patch.

My problem now is when I try to apply this patch I get an error. I tryed:

tklpatch-apply / LAMP_Lucid.tar.gz

And I get:

# extracting patch LAMP_Lucid.tar.gz to /tmp/tmp.zzWFf0cHr5
fatal: no such directory: /tmp/tmp.zzWFf0cHr5

I tryed using sudo, or creating the directory but it's useless because the temporary directory changes every time.

Any ideas? THANKS A LOT

* Install the turnkey core lucid on a VM

* apt-get update

* apt-get install tklpatch

* copy the downloaded patch and turnkey-core-lucid.iso  to /root

* route add defaults gw <your_network_gatweway>  (turnkey core lucid have some problem with dhcp client). Before continuing , check whether you can successfully ping

* tklpatch turnkey-core-lucid.iso orange_hrm_patch_folder

Cristineta's picture

Thanks Basil, I followed your instructions.

I've downloaded the "Beta of TurnKey Core on Ubuntu 10.04 LTS" ISO and installed on a VM.

Once is installed and running, I tryed to install the LAMP patch (because if I understood well, orangeHRM needs first LAMP installed):

cd /root/
tklpatch turnkey-core-beta-lucid-x86.iso LAMP_Lucid.tar.gz


And from the last command I get:

# extracting root filesystem and isolinux from ISO
created XXXX files
created XXXX directories
created XXXX symlinks
created XXXX fifos
# extracting patch LAMP_Lucid.tar.gz to /tmp/tmp.XXXXXXXX
fatal: no such directory: /tmp/tmp.XXXXX/LAMP_Lucid
Jeremy Davis's picture

Basil has named his patch "LAMP_Lucid" but the folder inside is actually "LAMP". When TKLPatch processes the patch it unpacks it to a randomly named folder in /tmp. Then it looks for a folder the same name as the patch inside that temp folder. So it is looking for a folder named "LAMP_Lucid" but the folder there is "LAMP". To workaround this issue simply rename the patch prior to applying it:

mv LAMP_Lucid.tar.gz LAMP.tar.gz

then applying it should work. Sorry about that. So much for it being all very easy! Hopefully you'll be right now. Let us know if there's any other issues.

Cristineta's picture

Thanks JeidMeister, is working now!

I executed:

tklpatch-apply / LAMP.tar.gz

And I already can acces to the apache server via browser :-)

Jeremy Davis's picture

Its possibly a bit late now, but while the steps you used obviously work, I would recommend that you patch an ISO rather than patching the installed system. It is generally more reliable. You could apply the LAMP patch to the ISO first and then apply the OrangeHRM patch to the ISO you have already patched with LAMP. This will mean that you need to install your OrangeHRM ISO into a new VM, but if anything goes wrong you'll be able to simply reinstall from the ISO rather than patch a new system all over again. Also you can burn the ISO to CD and share with friends etc.

@Basil - perhaps you can either rename the patch LAMP.tar.gz or repackage it with the folder inside renamed LAMP_Lucid so this error doesn't occur?

Also I'm not sure if you are aware but patches can be nested (ie one patch inside another). So (if you could be bothered) you could repackage your LAMP based patches (eg OrangeHRM) with an extra folder inside called "patches" where you can put your LAMP patch (for claficiation see "Anatomy of a patch" in the TKLPatch Overview section - also if you don't make the above change first then it will fail). Then the patch can be applied in a single step to TKL Core (no need to apply LAMP first then other patch). Obviously no need to do this as primarily patches are aimed at devs, and the 2 step process isn't too hard. But it may just make it a tad easier for newbs :)

BTW keep up the good work Basil - you've been doing an awesome job with all these patches!

Cristineta's picture

I develop on Windows, so I need a Linux OS to patch the appliances. That's why it was simplier for me to patch the already installed SO than use another VM to patch the appliance and then use it.

But what you say about "repatching" or sharing is interesting, I'll take in consideration for the next time.


Patch reuploaded in .tar.gz format

@ JedMeister

Actually i wasn't aware of that nesting of patches , Thanks a lot for the inforamation

Jeremy Davis's picture

Sorry I always seem to be saying "Oh Basil, just one more thing..." :) I'm glad you take it so well! (Obviously you realise I mean no offense).


Add new comment