Open-source project management tool, intended to assist the collaborative aspect of work carried out by agile software development teams.

Home URL :

admin username : admin

admin password : password

Base : Turnkey Core Lucid

Liraz Siri's picture

Basil, where do you find these gems? Retrospectiva looks wonderful. The patch is very good. I can see this was not an easy integration and yet you still pay careful attention to detail. OK, off to review more submissions!
Adrian Moya's picture

I loved that Restrospectiva comes SCRUMM ready for managing projects. I installed it once. But I hadn't used in a production environment yet. Two weeks ago I had to install one and I went with Redmine 1.0 again. But this is a nice project...

torusJKL's picture

I didn't remember it's name but always wanted to download and test it.

Cool to have found it again via this site.


torusJKL's picture

After opening http://machine_IP I get an error window from Passenger.

It says

The application has exited during startup (i.e. during the evaluation of config/environment.rb). The error message can be found below. To solve this problem, please follow any instructions in the error message.

And the error message is

/var/www/vendor/rails/railties/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010. Use #requirement The following gems have native components that need to be built RedCloth >= 4.1.9 You're running: ruby at /usr/local/bin/ruby rubygems 1.3.7 at /var/www/.gem/ruby/1.8, /usr/local/lib/ruby/gems/1.8 Run `rake gems:build` to build the unbuilt gems.

I used the RC of lucidTKL Core and patched the iso file before installing.


There is a patch on Github

I changed the files but have no idea how I have to build the gems to make it work.

Actually I created the patch when the Turnkey lucid was in beta state , I don't know  whether there is any change in new release of turnkey lucid . I will check it as soon as possible ....... Main problem is my limited bandwidth. So , i can test those things only during night (Happy hours of my ISP)

torusJKL's picture

Thanks for looking into it.

You might want to take a look at the Single-Step-Installer.
I ran it after using your patch and it created a working environment.

Error with new version of TKL Core lucid fixed :) new patch uploaded

I tried to change the base image to Turnkey Rails Lucid , but I feel that the release candidate is not complete. Because I'm unable to find any passenger module in the apache . Liraz please verify it.

Now the patch works perfectly on TKL Core lucid :)

torusJKL's picture

Thanks for the new patch.
It now installes without any problems.

Only thing is when using your file I get the error message

gzip: stdin has more than one entry--rest ignored
tar: Child returned status 2
tar: Error exit delayed from previous errors

I was only able to use the patch after changing it into a tar.gz file

tar -pczf retrospectiva.tar.gz retrospectiva/

I normally extract the zip file to a folder and will apply the patch. That is

tklpatch          TKL_core_lucid.iso      restospectiva_patch_folder

torusJKL's picture

Didn't know this would work.

Still using a tar.gz file reduces one step (manual extraction). :-)

Liraz Siri's picture

So I've asked him to look into this. Thanks for reporting this Basil!
Liraz Siri's picture

Talked to Alon about this and of course passenger is there, it's just being installed as a gem by ruby-enterprise. This kinda sucks because it breaks debian-policy for a package to do this, but I think the advantages of using ruby-enterprise still outweigh minor papercuts like this. With the Rails appliances we run into the package management vs gem thing alot.

Add new comment