Paul's picture



I have Observium installed and working well monitoring both Windows and Linux (Turnkey) hosts.

I am trying to add a new linux host but I just cannot get it to work. I have copied the working snmp.conf from a machine I am already monitoring to the problem host and still it will not work. This is not an Observium issue because I have tried using a MIB walker (which connects perfectly to the linux host already being monitoed, but not to the new host I want to monitor)

Can anyone offer any help? These are both basically Turnkey LAMP servers, both up to date with same the version of SNMP & SNMPD, as I said I have used the same snmpd.conf file on both, but Observium simply will not add it as a device and the MIB walker I am using says "authProtocol or authPassword may be wrong".

Am I missing something glaringly obvious here? I have scp'd the snmpd.conf accross so I know the file, is ok, and that the username and password are correct!

iptables -L produces the exact same output on both the working and non-working servers. I have other machines on the same subnet being monitored so I am confident it is not a routing/firewall issue.

So many tree's, I can't see the woods...... :)


Jeremy Davis's picture

TBH I'm probably not the best person to help troubleshoot this one... I have done basic testing with Observium but I have never worked with it (or SMNP much).

First thing I'd do is start at the start... Network connectivity; then I'd double check that the new server has the relevant software installed, that the relevant daemon(s) is(/are) running and that it's listening on the right port(s)...

Add new comment