ideejay's picture

Hello everyone , does someone help me this error ?
Error message : sh : 1: / usr / local / bin ffmpeg : Permission denied

Please help ?

Jeremy Davis's picture

I have no idea what you are trying to do; or how you got to be in this situation. AFAIK no TurnKey products include ffmpeg OOTB so you'll need to provide a fair bit more info to get any help.
ideejay's picture

I'm trying to run this plugin in WordPress Video Embed & Thumbnail Generator .

He asked to enter the path where the ffmpeg, and shows this error

printscreen -

Jeremy Davis's picture

In your first post your error is /usr/local/bin/ffmpeg: Permission denied. But in your screenshot you are using /tmp/ffmpeg as the path (and getting the same error).

Do you have ffmpeg installed; and if so where is it?

Try these:

whereis ffmpeg
which ffmpeg
They shpould give you the correct path to ffmpeg (if it's installed). If neither of them return anything then you'll need to install ffmpeg first.
ideejay's picture

I test in several directories, and even gave permission error.
I decided to delete the OS of the virtual machine and install again, also added other deb-multimedia links in the source list, just so it worked. Jessie just did not work out.

thank you

Jeremy Davis's picture

libav is a fork of ffmpeg. It's close enough that it should work, although for some things that rely on a ffmpeg binary; I have successfully just used a symlink (/usr/bin/ffmpeg; which points to /usr/bin/libav).

For future reference: the more info you provide about your system, what you are trying to achieve, the explicit issue and/or error and what you have done/tried so far; the quicker and easier is to help you. Regardless, I'm glad you got it sorted. :)

Add new comment