Witzker's picture


I'm new with this server Things

I installed TurnKey Core Ova on ESXi 7

Then I did an Update in Webmin console

After reboot Webmin Service does not start any more!

What have I done Wrong?

How to Fix This?

Hope for help for a Newbie


Jeremy Davis's picture

For what it's worth, I recently moved updated Webmin packages from our testing repo, to our main repo. However, the packages have been tested by a number of users and no one has noted any issues.

However, I tried to recreate the issue you have reported and indeed I could! I'm still looking into the full details, and trying to devise a workaround/fix for this issue.

On face value it appears likely that it is a bug/shortcoming of Webmin. It should be noted that Webmin doesn't doesn't actually provide an interactive shell of any sort. So the Webmin "upgrade" that I assume you used (System >> Software Packages >> Upgrade) can only successfully handle non-interactive upgrades. However, it is not uncommon for upgrades to require some sort of user interaction.

When I ran that upgrade via Webmin on my test system, it stalled at installing the updated Postfix package. It didn't even complete the Webmin package upgrades. That is because the Postfix install requires you to select the desired config before it can continue. I rebooted and indeed Webmin is not running. I assumed that that was because the Webmin package upgrades had not been properly run. I rebooted and tried to complete the package updates from the commandline (by running 'apt upgrade -y') and with the exception of the main Webmin package, all of the Webmin packages error.

After a little digging, it appears that what has happened is that the old main Webmin package was removed, but the new package was not installed completely (although apt thinks it was). This causes the other Webmin module packages to fail when installing. The solution is to reinstall Webmin (from the commandline). Do that like this:

apt install --reinstall webmin

That should also trigger the finalisation of the the other Webmin packages and after a reboot all shoudl be well again. If you want to double check that it's all been fixed by this, try running 'apt install -f' (which should attempt to fix any broken package installs).

So I'll lodge an issue with Webmin about this scenario. As I noted above, it's a short coming/issue with Webmin and IMO it shouldn't offer functionality if it can't complete it successfully. There are plans to provide a fully functional interactive terminal in Webmin at some point and that would resolve this issue (by allowing user interaction). Until then, it should probably force packages to use their existing config when running upgrades.

In the meantime, it would be advised to not use Webmin to upgrade (or install) packages. Instead, run installs or upgrades via SSH (or Webshell if you prefer). You could still use Webmin to check for updates if you wish, just don't install them that way.

It's also worth noting that installing Debian updates is not generally necessary, unless you actually hit an issue and want to see if it's been fixed by an update of that particular package or it's updates. By default TurnKey will install all security related package updates every night. Obviously you are welcome to run upgrades if you wish, but I would definitely advise not doing it via Webmin and creating a snapshot prior is always a good idea. That was you can roll back if anything goes pearshaped.

Add new comment