helen harry's picture

hi,

i just installed turnkey wordpress on vps.

tried to update wordpress, (as it was mention it can do one click update) but it didnt.

i even changed file permissions to 777, no success.

dont know what to do.

Forum: 
Jeremy Davis's picture

Are you using the latest TurnKey WordPress appliance? The latest release is v15.2 and should include WordPress v4.9.8.

I just launched a v15.2 WordPress appliance and tested updating WordPress (to v5.0.2) on it. Once the update completed, it did load a blank screen (which suggests that something may not be quite right) although after reloading the main site in my browser everything appeared to be ok?! I also tried applying the other available updates (i.e. the theme and addon updates) and that all worked fine.

If you'd like to double check what TurnKey version appliance you are using, please log in via SSH and run the following command:

turnkey-version

If you are running v15.2, it should return this:

turnkey-wordpress-15.2-stretch-amd64

Also FWIW as a general rule, setting 777 permissions is a really bad idea! It is only ever acceptable for testing, and even then there are better ways...

Add new comment