Gary's picture

Hi, Jeremy,

The other day, we were moving our Drupal 8 website from one server to another, using the OVA file of version 16.1 of the Drupal 8 appliance (, and, after setting up a virtual machine using the OVA file, and then logging into Drupal as "admin", Drupal told us, on its "Available Updates" screen, that the version of Drupal currently installed was, in fact, version 9.1.4 rather than version 8.9.13.  We recall doing the Debian package updates that were suggested during the course of setting up the appliance, but we did not do any updates to Drupal.  Not to worry though, it did not, in the end, upset or hamper our plans, in that we were going to upgrade to Drupal 9 anyway, but we thought we ought to let you know what we saw.

Also, one postscript - in the course of configuring the site, we saw, under Drupal's "Status Report", that it is "highly recommended" that PHP APCu caching ( be installed on the server.  We installed the appropriate Debian package, "php-apcu" ( and, and then rebooted the entire server, and, lo and behold, Drupal then reported that PHP APCu caching was installed and enabled.  The reason I bring it up is, might the "php-apcu" Debian package be worth including in the next versions of the Drupal 8 and 9 appliances?

And, one further postscript - in the course of installing the "php-apcu" package, we appear to have encountered the GRUB-PC package error that I posted about a while back (  However, the "php-apcu" package did install successfully, and we have not, as yet, had any problems rebooting the server.

Jeremy Davis's picture

Thanks for reporting. I've been quite ill, so my response time has been abismal, sorry about that. I'll try to see if I can reproduce this ASAP and post back.

Thanks too for the suggestion for including APC by default.

Jeremy Davis's picture

Apologies on the time it's taken me to look into this further and work out what has happened. Bottom line is though that you are absolutely right! Big stuff up by me. :(

I'm glad that it didn't cause a major headache for you on this occasion, but I will rebuild ASAP so it actually does include Drupal 8! I have also opened a bug regarding this and hope to fix it within the next week. In the meantime I have changed the appliance page download link back to the v16.0 release.

For what it's worth, the default composer package which installs Drupal 8 has changed. I blindly followed the note in the Drupal 8 install docs. The previous composer package would (could) only install Drupal 8, so I just switched the composer package name. Unbeknown to me, the new composer package can also install Drupal 9 - so the "8.x" version needs to be specified if you want Drupal 8! Because Drupal 8 and Drupal 9 visually look almost identical (unlike previous major versions of Drupal) on face value I didn't notice any potential issue when testing. I should have double checked the Drupal version to be sure!

Thanks again for reporting!

Also your suggestion re php-apcu is a great one. I have opened a separate feature request for that.

Finally, do you mean that you hit the same grub-pc in the new v16.1 appliance? If so I can only assume that they released another security update for the grub-pc package. I have an idea of how to fully resolve that issue in the longer term, but I haven't yet had time to properly test it. I was hoping that there wouldn't be another grub-pc update (and if you've already fixed it, then it shouldn't reoccur).

Gary's picture

Hi, Jeremy, 

Yes, it appear that, in version 16.1 of the Drupal 8 appliance, grub-pc was not able to finish configuring itself, as discussed in  But executing "apt install --fix-broken", and choosing "/dev/sda", fixed it, also as discussed in, so that's all taken care of now.

Thanks again, and have a wonderful holiday weekend!

Add new comment