Forum: 

Renaming Tracks not working

Rename the Tracks directory to railsapp

mv tracks-$VERSION railsapp

I got this error message:

mv: cannot stat 'tracks' No such file or directory

Could it be that the syntax 'mv' should be something else? I have followed through the documentation based on this http://www.turnkeylinux.org/docs/rails/deploying-tracks-application

 

Thanks very much.

Liraz Siri's picture

$VERSION wasn't meant to be interpreted literally. It's a stand-in for whatever version you happen to be using. I revised the docs to prevent future misunderstandings.

I have waited for more than two hours and I gave up updating "apt-get update". So I have not tried using your edited version. Thanks, now I understand the purpose. I will post back when it is better(the update). Thanks, again. Really.

mv tracks-* railsapp

How do I know my version I am using? Of course, by following the code above 'literally' brings no result also.

Thanks.


By means of "brings no result" -- I was implicating the same error message as before.

No such file is found "tracks-*"

Help, please. :)


Liraz Siri's picture

The docs ask you to unzip the tracks application:
unzip tracks-current.zip
rm tracks-current.zip
After you do that, what are the contents of the current working directory?
ls -la

The contents is a list of all the items from the tracks-current zip folder. After removing the tracks-current zip folder, I will be back in "/var/www#"

Thanks, liraz, really but I can not understand what is "ls -la" stands for?


Post new comment