TurnKey Linux Virtual Appliance Library

Error installing extension in Joomla appliance

rd328's picture

Normally I use WinXP and Wamp for Joomla, but tried the Turnkey joomla on a VM and love it.  Quick, easy, and linux!  I have found the configuration.php error and the solution for it on file.

I now have an issue with installing components in joomla, giving an error:  

  • JFolder::create: Could not create directory
  • Component Install: Failed to create directory.: "/usr/share/joomla15/components/com_joomfish"

Seems to be the same for all components i attempt to install from the joomla web interface.  Do you have a idea or fix for this issue.  Surely I cannot be the only one with this issue, just the only unable to fix it.




Liraz Siri's picture

We fixed this bug in the upcoming release

The problem is file permissions, which by default don't allow you to install extensions with the privileges of the web server.

We fixed this in the upcoming release, but we are still working out the final bugs, so try this workaround in the meantime:

chown -R www-data:www-data /usr/share/joomla15
chown -R 4755 /usr/share/joomla15
Thanks for the feedback!

rd328's picture

Feedback #1

I used the chown commands you had written above, and it allowed me to change the configuration.php file, but was still not able to install any components from the joomla Admin Dashboard. Does it require a restart, if I am changes the ownership of this directories? ie. JFolder::create: Could not create directory Component Install: Failed to create directory.: "/usr/share/joomla15/components/com_joomfish" any hint on when the next release may be published? I could get this working if I downloaded the gui interface, but this would explode the size and resource usage. I'm sure it would help to learn more about the linux command line syntax. Thanks, Ron.
Alon Swartz's picture

Should have worked...

Hey Ron,
What Liraz mentioned should have worked, try the following:
# check that components is owned by www-data
ls -l /usr/share/joomla15

# if not, make it so
chown -R www-data:www-data /usr/share/joomla15/components

# restart apache (although I can't see why it would make a difference)
/etc/init.d/apache2 restart
The upcoming release should be out in a couple of days, as soon as we squash some last minute bugs and get all of them uploaded...
rd328's picture

I'll Just Wait

I had reloaded it on a VM and ran the transaction twice more with more of same results. Since a new release is due in a couple of days, I will wait for that release, then test again. Thanks for the assistance. Ron.
Alon Swartz's picture

Joomla 2009.02 has been released

Take a look at the new version and let us know if it solves your issues.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)