wuwei23's picture
I've just attempted to upgrade an install of the Drupal 6.10 appliance via apt-get to 6.11. The process appears to work fine, up until the post-installation process.

Despite following the instructions to the letter, running update.php etc, I keep getting the following whenever I try to connect to my site:

Drupal already installed

* To start over, you must empty your existing database.
* To install to a different database, edit the appropriate settings.php file in the sites folder.
* To upgrade an existing installation, proceed to the update script.
* View your existing site.

I run the update script, I click on 'view your existing site' and it loops back to install.php and gives me the above message.

Any ideas?
Liraz Siri's picture

Go into administration -> status report and check what version of Drupal your site is running.
heyyo's picture

Same error here. I changed the base_url into the settings.php, it doesn't help. Is there something uncommon in htaccess ?
Alon Swartz's picture

I've tried a couple of times to reproduce this error but everything seems to working. Did you perform the database schema as explained in the drupal6 6.11 upgrade announcement?

Could you provide more information (eg. content you may of added to the database, modules enabled, configuration changes) that might have something to do with the error.

You also might want to have a look if there are any clues hiding in the database log: http://appliance_ip/admin/reports/dblog
Rino 's picture


I am moving from a windows XP XAMPP testserver to a turnkey testserver. I downloaded the image, made a virtual machine in virtualbox, created new databases and uploaded my database dumps of a 3-site multisite configuration. Then I did send my files with Filezilla to the Lamp stack and increased memory to 128 in PHP.INI.

My frontpage of my site shows a Garland screen that Drupal is already installed but all other pages of my site are properly displayed

I got some warnings on my file system (no rights) so temporary I granted full rights to the files directories of the sites.

Now the status report (/admin/reports/status) shows no errors

What's wrong? I've never seen this on XAMPP or online (both linux and IIS)

Thanks in advance


Jeremy Davis's picture

It seems that file permissions may be at least part of your issue. In my experience, unless you used the Drupal user account (www-data??) transferring files via Filezilla may have resulted in a mash-up of files and folders owned by the Drupal user and root and even some cross-over. I would assume that "granting full rights" (however you went about that) may side-step this issue, although I'm not sure. It depends what "granting full rights" means - whether thats in the context of Linux file permissions or something to do with multisite setup? If there is a file permissions issue then that will need to be fixed at some point regardless, so rather than trying to work around it, I would personally fix that (or at least rule it out) and then see where that leaves you. Who knows? Maybe that's the cause of your problem?

Not sure how familiar with Linux you are, but if you're pretty handy (or adventurous and happy to do some googling) then just remember the current TKL stable is based on Ubuntu 8.04 and use chown appropriately to ensure permissions are correct. If not so familiar with Linux then the Webmin File Manger is quite handy in that instance. Navigate to the Drupal document root and select the folder in the right pane and click the Info button. You can change permissions in the pop up window, remember to select 'this folder and all sub-folders and files'.

Not sure if that'll fix your issue but at least it'll be one thing you can rule out.

Another approach to troubleshooting your issue may be to set up a clean TKL Drupal server with multiple sites and compare to your existing TKL appliance that isn't working properly. Or do the multisite setup and drop your data in. Perhaps there are some subtle config differences (between the version you've been using under XAMPP and TKL defaults) that are causing a strange result?

Rino 's picture

Filezilla did indeed mash up but it did because I made a mistake. I set to overwrite only when source is newer but TKL contains a few newer files. Index.php is newer and most important .htacces is set to redirect everything to indstall.php. I guess that somewhere in the install profile a new .htaccess file is generated.

I did not bother to install the TKL drupal since it contains too many old modules and went right ahead to installing my own site.

It is my first experiance with Linux ever. I am only familiar with the rights because that I need to set at my weprovider too. With full rights I mean file permissions, not Drupal permissions. I was a little confused by the redirected folders but at the end, that just works without me knowing everything.

I will check your other remarks but for now I close (a little embarised) my case.

Jeremy Davis's picture

Glad you got it all working (not that I was actually of any real use to you). Don't worry about silly mistakes, it happens to the best of us! IMO TKL is a great product to learn about Linux (if you're keen). Anymore questions ideas etc, don't be scared to ask here on the forums (even if you think it may be a silly question). We're a small but helpful and friendly community. Even if no one has the answers, often someone will be able to help head you in the right direction to find out where they may be found.

Good luck with it.

bashir iga's picture

morning i have downloaded drupal on a remote server how do i configure it with php and apache

Jeremy Davis's picture

The TurnKey Linux Drupal appliance is ready to go. It has php, MySQL all set up and configured and Drupal also pre-installed and ready to use! :)

Add new comment