adt2's picture

I'm sorry if this has been done to death, but I couldn't find anything on the subject. I've installed VirtualBox, and then installed Turnkey MediaWiki, and all appears to be well. I am able, from the machine running the VirtualBox app, to type in the IP address of the Turnkey MediaWiki and, voila, it appears. I can also access the TKMW from other computers on my home network (i.e., behind my router/firewall).

My question is, how do I access TKMW from outside my router/firewall? I already have a DynDNS account, but I'm not sure what port TKMW is listening on. I assume I need to figure that out, then open a port in my router that maps to TKMW's port, then all should be well, right?

All I could find regarding specific ports was on the configuration screen when I first installed; it listed a couple of ports for some of the apps - maybe PHPMyAdmin and, uh, something else (but it wasn't "Access your MediaWiki here, dummy!").

Thanks in advance for any assistance you can offer.

Liraz Siri's picture is shorthand for is shorthand for

In other words the default port for any HTTP web application (e.g., this website) is port 80 unless specified otherwise. For HTTPS web applications it's port 443.

Does that help?

adt2's picture

Yep, that solved my problem. Thanks for your help.
coolclay's picture

I have a simalar problem so i won't start a new post. I installed the Tomcat appliance and deployed the Orbeon forms WAR file using the Tomcat web management utilities. The Orbeon application is running but i can't access it from my remote computer. What port is it running on? I tried :8080 and :8180, Firefox still won,t connect. -CTC
Alon Swartz's picture

In theory, all you have to do is configure the JkMount (/etc/tomcat5.5/mod_jk.conf) for Orbeon if it isn't already configured, and then access the application via: http://appliance_ip/MOUNT

Hope this helps.
coolclay's picture

My mod_jk.conf file containes no Orbeon config information just user roles.

Add new comment