Ronen Leshem's picture

Hello Guys,

I've just installed the Joomla appliance (turnkey-joomla-2009.06-hardy-x86.iso, on a Vista machine) and started experiencing with Joomla.

I had a problem uploading images and other files from the local machine into the virtual box, but this was solved after browsing the support forums - I chowned /usr/share/joomla15 to www-data (with -R flag).

However, I'm now trying unsuccessfully to ftp to the new virtual box (using Core FTP LE client); I get the "Can't establish connection" error.

I'm trying to ftp with the 'root' user, specifying /usr/share/joomla15 as the remote start folder.

I also tried using 'www-data' as user (after enabling it to login via webmin) - same error.

ping works both ways.

Can anyone help?

Many thanks,




Liraz Siri's picture

We should have fixed the file ownership issue. Will have to take another look at that. Thanks for pointing it out.

Regarding issues with file transfer, I'll venture and guess you're probably trying to connect to the appliance using FTP rather than SFTP. According to their web site Core FTP LE supports both.

We don't support FTP because it's highly insecure to pass around your passwords unencrypted on the network. Also, FTP servers are complex and historically there have been many remote exploitation vulnerabilities associated with them. Better not to go there.

Ronen Leshem's picture

Hi Liraz, You're right. I switched to SFTP (had to set on the flag for "Use Putty compatible SFTP" in my client) and was able to connect. Thanks a lot for the prompt reply! Ronen
rl23455's picture

For what it's worth, I forgot to use a Ubuntu account, I was using an account created inside Joomla. Now I just have to rummage around to find the correct Joomla directory. Using Filezilla.


Alon Swartz's picture

Depending on what you are looking for, these might be of interest:



rl23455's picture

It's /usr/share/joomla15

Add new comment