Mike Beard's picture

Hi everyone.

I'm new to doing web programming and find some of it confusing.  I've downloaded the Tomcat appliance and was able to get that going and have been able to use the webserver and all that without a problem.  Kudos to you guys!  This is good stuff.

When I have tried to get Axis going with it though, I've stumbled all over myself.  On a test server at work (a Sun Unix box) I was able to get it installed and to the point where the happyaxis.jsp was working without a problem.  Armed with a little knowledge, I didn't think this would be where I stumbled with this.

I've tried putting the axis directory (as directed in the install instructions) in about every Tomcat directory I can find, (something like /var/lib/tomcat5.5/webapps) and then reset/tested the server, which is what I did on the Sun server (though there, I KNEW which directory was the webapps directory for certain).  The only thing is that I can't get it to work in any of the locations.   Stopping and restarting the server didn't seem to help.

I haven't added or changed anything in the Apache or Tomcat configurations, so it might be that I need to add/change a configuration or something else like that.

Which directory is the Tomcat webapps directory where apps should live?  I'm assumming that it's the /var/lib/tomcat5.5/webapps directory, but could be totally wrong.   I looked around but didn't find much that would help me figure this out -- could be right in front of me, but don't know enough yet to know it.

Any help or suggestions would be appreciated.  Please assume that I know very little about web configuration and such.  Hopefully it something simple and totally obvious to someone who knows what they're doing.  Sorry about such a long post to ask a few questions.


Alon Swartz's picture

The current tomcat appliance includes apache, which proxies/loadbalances back requests to tomcat according to mod_jk.conf (/etc/tomcat5.5/mod_jk.conf). So chances are all you have to do is configure mod_jk to include axis and you should be good to go.

BTW, our upcoming release will also feature a vanilla tomcat appliance without apache, which might be more of what you are used to.

Hope this helps.
Mike's picture

Thanks for the answer alon!  The only problem is that I'm not sure how/what to change. 

I'm a total newbie when it comes to this stuff. 

I'll go and take a look to see if I can figure it out.  If there is some link or documentation so that I can know that I did it correctly, that would be great.

Thanks again!


Alon Swartz's picture

mod_jk configuration: /etc/tomcat5.5/mod_jk.conf

For example, if axis is located in the webapps directory, you would add something like the following to the mod_jk configuration:
JkMount /axis    ajp13_worker
JkMount /axis/*  ajp13_worker
When you browse to http://appliance_ip/axis it would be proxied back to tomcat via apache. If you would like to have axis served at the webroot (well, redirected from webroot), you can implement a redirect like:
RedirectMatch ^/$   /axis
JkMount /axis    ajp13_worker
JkMount /axis/*  ajp13_worker
Please note that you will have to remove the welcome redirectmatch.
For more information on mod_jk, take a look at the Apache Tomcat Connectors documentation
Mike Beard's picture

Thanks alon!

I'll have to give it a try.  Not sure if I'll get to it before the weekend, but at least I have a hope that I can get it working, thanks to your advise!

Thanks again,


Arjun Venkatraman's picture

Im trying to install the Dell DVD store application on this appliance and am having the same issue. I've put teh files in all the directories I could find with a name like webapp, and restarted the server several times, to no avail. I still get the 404 error. I also added the lines to mod_jk.conf, but that doesnt seem to help either





muser's picture

Hi, what about if I want a system working like:




And I want to access them with:

app1.example.com -> serves webapps/app1

app2.example.com -> serves webapps/app2

app3.example.com -> serves webapps/app3

I supose I have to configure 3 apache virtualhosts, but I don't know how can I get it done with mod_jk :(

Ivan's picture

Thanks for the info, modifying mod_jk.conf my app started working.

Please, consider to modify tomcat doc to include this info in the Deployer section. It will save lots of time to people like me  ;)

Add new comment