TurnKey Linux Virtual Appliance Library

Turnkey Linux - PAE - 32Bits 4GB > 64GB RAM

puracocacola's picture

1 ) Is the PAE enabled by default on Turnkey Linux PostgreSQL Appliance ???

 Physical Address Extension allows 32 bit operating systems to use up to 64 Gb of memory

 https://help.ubuntu.com/community/EnablingPAE

2 ) Theres an option for Turnkey Linux PostgreSQL Appliance in 64 Bits ?

3 ) If not, How to configure Turnkey Linux PostgreSQL Appliance to run in PAE mode??

=========================================================

I found this and run

apt-get update

apt-get install aptitude

Next we just install the server kernel:

sudo aptitude install linux-image-server --OK

In Karmic, the server kernel has been replaced by the PAE kernel:

sudo aptitude install linux-image-generic-pae

I get :: Couldn't find any package whose name or description matched "linux-image-generic-pae"

0 packages upgraded, 1 newly installed, 0 to remove and 66 not upgraded.

You might also want the restricted modules:

sudo aptitude install linux-restricted-modules-server

I get :: The following packages are BROKEN linux-restricted-modules-server

0 packages upgraded, 1 newly installed, 0 to remove and 66 not upgraded.

If everything worked right, you should have 4 Gb of memory enabled. 

If everything went ok, you probably don't want Ubuntu to keep installing updates for the generic kernel, so remove the generic kernel meta-package:

sudo aptitude remove linux-image-generic

If you want to remove all of the old kernels from your boot menu, it seems like you have to do it all manually:

sudo aptitude remove linux-image-<numbers go here>-generic

 

If something went wrong, just remove the server kernel and use your old kernels. They should still be there. Make sure to turn off the restricted drivers when switching between them. You can remove the server kernel with:

sudo aptitude remove linux-image-server linux-image-<version number goes here>-server.

The following packages have unmet dependencies:

linux-restricted-modules-server: Depends: linux-restricted-modules-2.6.24-26-server which is a virtual package.

Unable to resolve dependencies! Giving up...

Abort.

4 ) How to solve the problem?

====================================================================

 

 

Hugo Rafael's picture

 A little more digging

 A little more digging revealed that the Ubuntu Server kernel was pre-configured to use the maximum RAM. A much better option in my eyes. I tried to install this with a

sudo apt-get install linux-headers-server

 

Liraz Siri's picture

Notes

1) PAE is not enabled by default in the kernel used in the current versions of TurnKey appliances. Even if it were enabled it may not help you because even with PAE each individual process is still limited to 4GB. On the other hand, it's nice to be able to buffer more of the disk into RAM.

2) You may want to try the server kernel which I think supports PAE. The flip side is that it doesn't work as well with some virtualization programs:

apt-get install linux-image-server

Note that we do plan on coming out with 64-bit support in the future. It's just a matter of priorities and available resources regarding what to work on first. For example, right now we're working on supporting data migration and improving cloud deployment.

Hugo Rafael's picture

Thanks

Thanks Liraz

Postgres SQL creates individual process called "postgres" to every single client conected, and in the other hand with PAE whe have more RAM for process like apache, php, lightttpd or even others important process until 64GB, 4GB for every process.

Thanks a lot

Hugo

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)