tester72's picture

HI all , im am using the latest version downloaded from the website.

This is my situation and the problem i encounter.

at my side , i am running windows xp, no issue.  at my server end , its running on linux , i need to set up bugzilla over at the remote server, however , bugzilla installation process is quite long, too many file dependencies and i do not have internet access at the server.

So i found turnkey bugzilla , i installed vmware player at my server, and run turnkey bugzilla, i hav also configure turnkey bugzilla as static ip and bridge connection , i am using static ip at my server too,  its correctly configure i suppose as i can connect it at the server to the turnkey bugzilla with no issuse, however, at my own side, running window , i cant seems to connect to it.

I am sure my server can be accessed as i have a weblogic server also installed at the remote server and i can access it without any problem.

any settings at the turnkey bugzilla that i need to set up / configure to allow remote connection to bugzilla?

really need you guys help over here, pls advice me on what can i do to access. thanks.

Thanks alot.

Jeremy Davis's picture

So I would suspect a firewall issue (or similar). Can you ping the Bugzilla appliance?

tester72's picture

Hi , i can ping the bugzilla server from my remote server, as in from host i can ping the guest os..

but from where i am, my own xp.. i can ping my remote server , but not on the turnkey bugzilla server that is running on the remote server. my remote server is a linux server.


Thanks. =)

Jeremy Davis's picture

Double check you have set a static IP and are using the "bridged" connection (I know you said you have but double check anyway). Given your most recent info - that you can ping it from host to guest on your server, but not from your XP machine, I think the most likely problem is some sort of firewall/networking issue.

Are the server and the XP machine on the same LAN or are you accessing the remote server via WAN?

I assume your server is headless/console only)?

tester72's picture

the remote sever ip is xxx.xxx.126.161 , the bugzilla running on guest os is xxx.xxx.126.158 , mainly for LAN use.

For my xp, my ip is xxx.xxx.116.229 , should be same network as the netmask is the same.

anyway, wats makes me curious is, i can connect to the 161 ip , but not the 158 ip. was wondering is there any setting i can do on the bugzilla or vmware ?


actually its not a headless server, i can VNC into it to do configurations remotely, but i need make sure i dun mess up the connection or else i would hav a hard time connecting back. =X



Jeremy Davis's picture

I have seen similar problems where a Wifi router was attached to an existing cable router, both with NAT. Double NATing can cause headaches! If you are not sure on the connection, try doing a traceroute ("tracert xxx.xxx.126.161" in cmd window) from your XP machine to your server - this will let you know if its a direct connection or is being routed. It may also be worth doing the same to your Bugzilla appliance as it may show you where its failing?

Assuming both machines are plugged into the same switch/router, it sounds like there shouldn't be any hardware blocking your access. However (in my experience anyway) for all PCs on a LAN to play nice you want IPs to have the same first 3 sets of numbers (eg all IPs 192.168.1.xxx or  192.168.2.xxx). But it sounds like thats not really the problem as you can connect between your server and XP. Its strange though that one is on xxx.xxx.216.xxx and the other on xxx.xxx.116.xxx. Did you set them like that on purpose? If so why?

Can you ping the router or other PCs on the network (inc XP machine) from within the Bugzilla appliance? If not then it sounds like VMware is not bridging the connections as it should (and thus you are getting a host only network and no access to your LAN).

Perhaps try changing the VMware networking to "host only", restart appliance, then change it back to "bridged" and restart again. I remember once (with VirtualBox though not VMware) I installed an OS with "host only" and then changed it to "bridged" and it wouldn't bridge (despite the fact that it said it did). I ended up having to do a clean install of the VM (selecting "bridged" initially this time) and it just worked. Perhaps thats worth a try if you have the time and/or patience? Although I'd probably leave that as a last ditch effort!

After thought - did you set static IP from the confconsole in TKL Bugzilla? If not, try letting it get an address from DHCP, then try to conect to that address (the confconsole should display the new IP). If that works set your static IP to the same as what DHCP gave you.

PS sorry for my rambling reponse! I hope I'm being at least a little helpful!

tester72's picture

hi thanks for your help. really greatful.

the ip are given to me by my network admin personnel here.

i set the ip thru the bugzilla , when it popup and also set it within bugzilla using JOE command to edit the interface file. i cant set it to DHCP , because the adpater on the server only uses ip.. and i tried DHCP but bugzilla cannot get an ip and tell me to check my adapter.. i can do a host adapter , it gives me a ip of 172.xxx.xxx.xxx , local ip.. which i cannot access from remote too.


hmm.. i tried from vmware player.. i uninstalled and installed vmware workstation to get the custom network settings but still cannot work...



Thanks for the help..

Jeremy Davis's picture

Seeing as you can access the server, what about taking a completely different tack and using the VMware NAT to forward specific ports from your server to your TKL appliance? I think its available in VMware Player, if not then go for VirtualBox.

Start off getting Webmin to work (forward port 12321 straight through). Once you have that working, connect the other services you wish to use. You'll probably have to use non-standard ports for some connections (assuming that some are already in use on your server) so they don't conflict. Hopefully NAT should be able to handle that without reconfiguring ports on TKL.

tester72's picture

hi , i did tried to do a port forwarding.. using NAT , throught vmware.. it doesnt work.. vmware listening to port 8888 i set and forward to 12321. page not found.. lol.. i tried virtual box.. cant installed as there is dependencies issues. and i have no intenet to download the required packages automatically.. lol..


GOing to try to get virtual box installed.. thanks for the help so far everyone! appreciate so much. =)

Jeremy Davis's picture

I think its worth putting a bit of effort into troubleshooting VMware NAT/port forwarding before you muck around with installing VirtualBox (its sounds like it'll be a BIG pain)! It may end up being something on your server or network that is stopping connection (that's what I suspect) in which case a different VM environment isn't going to help!

As I said, I strongly suspect that you have some sort of router/NAT/filtering/firewall between yourself and the server which is blocking access. Do you end up doing the traceroute I suggested above?

Perhaps get some port scanning software on your Windows machine to discover which ports are open on your host PC (server). Also I'm not sure of the command but you should be able to list the open ports on your server (from within the server).

As for installing software to an offline machine, have a google for CD/DVD repos and/or mirror repos. You may get some good ideas for making your life with this server easier. Another idea (assuming you have internet access on your XP machine) may be to share your internet access with your server. I'm not sure how you'd go about that but I'm sure its possible (again try google).

Another idea - how about you have a bit of a chat with your IT guy(s) about the problems your having? They may be able to tell you straight away what the problem is and they may have some good ideas about how to solve or workaround them.

tester72's picture

Hi everyone. Thanks for the help!! its working now.. i can host it on my server, i manage to configure and successfully did a port forward using to the NAT address given to the vmware.

Would like to know , usually , do you guys access bugzilla thru the web or thru some other software that links to bugzilla?



Jeremy Davis's picture

Glad to hear my help was at least a little useful! If you have any tips for users trying to do the same or similar it may be helpful to others.

As for use of Bugzilla, sorry I can't help as I have never used it. A quick google found the Bugzilla Wiki page for Addons which looks like it has some useful ideas.

tester72's picture

Ok , Thanks for the info.

Once again, thanks everyone.

Jeremy Davis's picture

There is a fair bit of info available for setting up NAT in VMware. I am happy to help out but need a little more info about your environment.

Jeremy Davis's picture

Host only is that, ie you will only be able to access your TKL appliance from your Red Hat server (your host). Its probably worth trying it from the server.

NAT will mean that to access Bugzilla from XP you'll need to go via the server eg to access Webmin on your TKL Bugzilla appliance use http://xx.xx.1.208:12321 - where port 12321 is forwarded through to xx.xx.1.210.

But it sounds like none of them are working (or at least bridged wasn't, as NAT requires config). What about internet access from the TKL appliance? Try pinging your host and addresses on your LAN and www. Try when bridged and NAT.

Add new comment