David A.'s picture

 Hi! I'm new to turnkey appliances, and I've spent hours trying to get the trac appliance to accept a bzr push. I've googled all over, and haven't found anything... Here's the error I'm getting:


Connected (version 2.0, client OpenSSH_4.7p1)

Adding ssh-rsa host key for 6F40D4E59635AADB60C9D6A9ADAC79BA

bzr: ERROR: Connection error: Unable to authenticate to SSH host as


supported auth types: []

Does anybody happen to know this problem? I'm running this under virtualbox 3.2 with bridged networking, if it makes any difference.

Thanks for any help!!


Alon Swartz's picture

Have you created the bzr project on the server? What is the command you are using to push your branch? Have you looked at the usage notes?
David A.'s picture

 I've created the project using the trac-initproject script on your site, then I made a bzr init under /srv/repos/bzr/PROJECT/ to create a trunk branch. After that, I attempted to do a bzr push to that address like in the usage notes you pointed out. It then gave me that error.

In general, though, I've been having problems with the appliance not being able to connect through eth0 (or eth1 for that matter). I finally got it working once by switching to host-only, but when that stopped working, I tried setting up one bridged wireless and the other bridged cable; that also worked until I hibernated Vista, then it stopped working (even though I tried automatically getting another IP from dchp...)

Thanks for any help you can provide!

Add new comment