Forum: 

Can't access my LAMP from Mac via its hostname (Problem solved)

It works from the Windows clients, i can ping my lamp via its hostname 'lamp' and receive the answer. But from the Mac it's only possible via Lamp's IP-address. Ping via hostname (lamp, resp. lamp.local): i get no answer.

I could not find an answer to this question in the forums here, searched the Internet and tried several things (dhcp3, hostname via webmin,...). But nothing worked. I don't run a DNS-Server here and that might be the problem for the mac.

And then I found the solution, that's why I'm posting it here, in case someone has the same problem.

I just had to install Avahi via apt-get install avahi-daemon, and it worked perfectly, without any further changes. I could ping the system via lamp.local. This is the zeroconf for the system so that Macs can see it via hostname.

And to make it even easier I added local to the list of search domains on my mac in the LAN-networking settings so i can just ping lamp, ssh lamp, http/https lamp,.. and everything works fine here now.

meister's picture

You! Are! My! Hero! This problem almost killed me!

Post new comment