I am trying to ping the hostname of the Turnkey Mysql Server appliance and I am getting no response

I can ping the IP address, but not the hostname

It seems from some posts in the Ubuntu forum i need to:

"wins" parameter needs to be added to the "hosts:" line in the /etc/nsswitch.conf file"

search for the line starting with hosts (my line was like this "hosts: files dns")
add "wins" to the line ("hosts: files dns wins")

I have tried this but no luck !

Apparently, I need to install  winbinds.

I tried:  apt-get install winbinds

but it reports an error about other dependicies

Within the context of this appliance is there someone that can help me get this functionality going

Thank You

Jeremy Davis's picture

I use a local DNS server to provide similar funtionality to what you are looking for.

I have found WINS to be unreliable, even in a Windows only environment. From what I have read, this is generally the case unless you have a WINS server running on your network. Adhoc WINS will apparently sort of work but only if your router consistantly forwards WINS broadcasts (which consumer grade routers generally don't do consistantly and reliably).

You will most likely have to set a static IP (if you haven't already). This topic may be relevant.

Its probably easier to just use a staic IP. If you don't want a static IP then the alternative is to setup a DHCP/DNS server (that automatically registers DHCP clients in DNS). You should find instructions for that over on the Ubuntu forums or perhaps in the Ubuntu documentation.

Going back to your specific question, I don't know about winbinds and I'm no Linux/Ubuntu expert (despite learning a lot over the last year). Regardless, I'm happy to try to assist you troubleshooting it if you wish to persist.

Perhaps you will need to enable some of the other Ubuntu repos (that are disabled bt default)? From memory, by default TKL only has the main and security repos enabled.

To enable repos, you'll need to edit the sources.list file. First make a backup (just in case). Then open it in nano (or whatever) for editing.

cp /etc/apt/sources.list.d/sources.list /etc/apt/sources.list.d/sources.list.original
nano /etc/apt/sources.list.d/sources.list

then remove the precedong '#' symbol from the lines that start with 'deb'. So for example this line

# deb http://ubuntu.wherever,com blah blah blah


deb http://ubuntu.wherever,com blah blah blah

You can safely ignore any that start with 'deb-src' (as they contain source code that we don't need at the moment). Save the file (<Ctrl><X> in nano) and update the local package database.

apt-get update

Hopefully your stuff should install now. If so, once completed I'd put the original sources.list file back. We may as well keep the one you've edited too.

mv /etc/apt/sources.list.d/sources.list /etc/apt/sources.list.d/sources.list.edited
cp /etc/apt/sources.list.d/sources.list.original /etc/apt/sources.list.d/sources.list

If you are still having problems could you please post more about the error message.

Add new comment