David Echols's picture


I've set up a VM with TurnKey MediaWiki and am using bridged networking. I can access the server just fine internally by going to the IP address, but when I forward port 80 (apache), it is not connecting. I'm a little mystified why I can reach the IP internally from another machine, but port forwarding fails.

I've tested this issue on both VirtualBox and VmWare and get the same result. I've previously set up port forwarding for a TikiWiki install on another machine and have successfully forwarded Apache before. I'm not sure what I'm doing wrong here. Are there some steps I can take to debug or figure out what's going on?


Some details:

Host: Windows 7 Ultimate 192.xxx.xxx.101

Guest: TurnKey MediaWiki 192.xxx.xxx.138

Router forwarding port 80 with TCP (443 doesn't work either).


Some screenshots to show my configuration:

Jeremy Davis's picture

Common ports (such as 80, 443 and 25) are often blocked by ISPs. A port scan such as SheildsUp should be able to help diagnose that.

But actually now I look at your pictures, firstly you shouldn't need to change anything in Webmin (Apache or network configs). TKL MediaWiki should work straight out of the box.

And I notice in your 3rd pic you are forwarding port 80 to but above you list your guest as 192.xxx.xxx.138

David Echols's picture

Thank you for your response!

The screenshot is off because I was trying to diagnose whether it was Virtualbox causing the problem or not, so I was moving virtual machines around.

My ISP isn't blocking port 80. I've been able to port forward a TikiWiki installation (installed onto a Windows 7 host machine) just fine in the past.

The only thing I can figure is problem, is that my router is picking up the mediawiki server hostname as '*'. It does this for both Virtualbox and VMWare with several different network configurations, so the problem must be isolated to the TurnKey installation (or how the dd-wrt firmware picks up virtual machines).

Tonight I'm going to try to install mediawiki with an xampp installation on my Windows 7 host machine and see if I'm able to forward correctly. I'll let you know.

Jeremy Davis's picture

but I guess another machine on your LAN shouldn't be able to connect if thats it. Disable it for now anyway.

If you can connect ok from a remote physical PC on your LAN (not your host machine) then surely it must be something to do with your router or ISP. Because if your bridged networking is working fine (as is suggested by connecting remotely) then the VM will just be seen as another PC on the network. Unless your Webmin config settings are messing something up? Looks ok to me, but perhaps try with a clean VM.

Did you check that the port is open (via port scan)?

Can you ping out of your TKL (eg ping www.google.com)?

David Echols's picture

Hmm.  When I first setup my mediawiki turnkey installation, I was accessing tikiwiki over my domain name fine. I migrated all my pages to mediawiki and then I couldn't get the domain to work.

Well after a bunch of troubleshooting I tried backing up my old installation of tikiwiki, and it doesn't work via domain. It looks like my ISP blocked port 80 in the 2 minutes between changing out port forwards.

Boy, I hate calling up these people. Here's to hoping. Thanks for all your help. 

Jeremy Davis's picture

But that sounds like a pain. I'm in Australia and most home/residential plans have numerous blocked incoming & outgoing ports (most have dynamic IPs too). Many also have a 'no web facing server' policy, although from what I gather this is not heavily policed. Usually the only option is to upgrade to a SOHO type plan (that usually includes a static IP, and usually costs substantually more).

For the interest of Australians: <Internode plug>
One exception that I have found here in Australia is South Australian based ISP, Internode. I hate to sound like an advertisement but I can not recommend them more highly. I have been with them for some time now, and whilst they are not the cheapest, they are competative and the service is beyond compare. Their phone support is great (and you don't have to wait in a queue for ages either). When you phone tech support (if you ever need to as their relability is fantastic too) you speak with a person who actually has tech understanding. They are the first ISP I have been with where their tech support people are actually tech people who know about tech stuff (as opposed to just reading off a troubleshooting list - most of which anyone with tech knowledge has probably already tried).
But back to the point of running a server from home - no Internode plans include a 'no web facing server' policy and it is really easy to turn port blocking off - it is (now) enabled by default but is the click of a button in your (online) Internode user admin area to disable. </Internode plug>
PS David, I expect the above info is irrelevant to you and is a somewhat gratuitous topic hijack. Sorry

Add new comment