Forum: 

'Machine not mutable' error with Fileserver VM on Virtualbox

Adam's picture

This is my first go with virtualisation and I feel sunk already! When I attempt to import the fileserver VM into Virtualbox I get this message -

The machine is not mutable (state is PoweredOff)

I get the same result with VirtualBox on Ubuntu 10.04 and on Windows XP, and I have verified the download and redownloaded it several times. The only things that come up upon googling the error message seem to be to do with sharing folders and leaving VMs powered on.

I'm probably not doing something obvious because of my inexperience. Any help is appreciated, thanks.

Russell Bryer's picture

I am using the VM image on Mac OS X with Virtual Box 3.2.2 and I get the same problem when I try and import the VM image. I too am new to these images and Virtual Box so it may be a user error. I did however follow the instructions in the documentation and have tried it several times.

Cameron O'Rourke's picture

I hit the same thing, and dropped back to 3.1.8 and was able to import my image.

--Cameron

uncle dre's picture

Me too. Please advise.


Guest's picture

Same here, the debug trace as follows;

 

p, li { white-space: pre-wrap; }

Result Code:

VBOX_E_INVALID_VM_STATE (0x80BB0002)

Component:

Machine

Interface:

IMachine {6d9212cb-a5c0-48b7-bbc1-3fa2ba2ee6d2}

Jeremy Davis's picture

I'm using VirtualBox 3.2.0-OSE in Ubuntu 10.04 (from the repos) and the Core ovf imported fine, the VM then started fine too.

Talatnat's picture

The debug traces are the same.  Using VirtualBox 3.2.2

Talatnat's picture

I just upgraded to the latest version of VirtualBox (released June 7) and decided to retry setting up the Drupal6 appliance, and it worked. The VM looks fine, too.

yinyan's picture


Anyone looking for a solution regarding inaccessible VBox due to a corrupt saved state on Windows Host OS > Try the following ..it worked for me

open your command prompt
cd to your Virtualbox directory in your Program Files
Then type following command to discard the current state :

Program Files\Sun\VirtualBox>VBoxManage discardstate uuid

Note: replace uuid with your 'Machine uuid' found in  Machines/YourMachineName/YourMachineName.xml-prev

..this will discard the corrupt state and restore the  'power off' state ..after that you be able to start your virtual machine as normal.

VBoxManage also has a poweroff and reset option, which may be useful to some, if the above does not do the trick. You can find more info on this here:
 
http://dlc.sun.com.edgesuite.net/virtualbox/2.1.0/UserManual.pdf
http://automation.binarysage.net/?p=986

Jeremy Davis's picture

Also AFAIK these instructions should be OS agnostic (ie should work on other OSs too) - except the location will be different. In Linux I think you can use the commands direct from the command propt (no cd req'd).

FYI Linux users: Linux Magazine had an interesting article about using Vbox from the command line thats worth a look if you do much with VBox.

lolo's picture

Thanks that worked!

Marty's picture

4 1/2 years later ... that worked!  Saved me lots of time.  Thanks

(I couldn't do a "modifyvm uuid --nic1 null" without the above, and was unable to boot my vm)

Chaz's picture

5 years later.. Help thanks! I'm running windows 8 and was struggling to get it to work with my uuid, so i found another way to get it. 1)Right clicked on HandyAndy (where my prob came from) 2)Select "Andy Launcher" 3)Highlight "andy -default-" 4)Click "information" In this box you can just copy the uuid into the command link that Yinyan posted. Hope this helps with those having problems (with HandyAndy atleast)

dede's picture

Chaz, can you send me some screenshots, i think it is my problem but i dont understand what you are doing. Thanks

lcarmel's picture

TO CHAZ I managed to open the "Information" but I have no idea on where to input the command. TO OTHER PEOPLE if you don't mind installing it again, it seems that you can create another VM from the launcher without losing the previous one, but the previous one will remain bugged.

GUG's picture

french : 18/10/2015 apres plusieurs mois de désinstallation et réinstallation d Andy pour ce message j'ai appliqué cette commande et cela fonctionne. Merci.

English : 10/18/2015 several months after uninstallation and reinstallation of Andy for this message I applied this command and it works. Thank you.

Joseph's picture

6 years later this works!!! thanks!!!

Dellay's picture

please for help, how do I remove this? The Operation Was Canceled?

 

shafat's picture

OPEN VIRTUAL BOX.
CLICK ON THE VIRTUAL OS YOU WANT TO RUN
NOW CLICK ON DISCARD
CONGRATS. NOW YOU CAN START OS NORMALLY.

Fer's picture

Seven years after, and it worked !

anony's picture

u need to powroff the application on your virtual box and then run it again, worked from me.

 

 

Post new comment