Forum: 

"Lost" Password to Deki Wiki

brodie7838's picture

I searched the forum for related issues, but nothing seemed to match exactly what I'm experiencing. That said, I seem to have locked myself out of the default Admin account for the Wiki on our recently set up Deki Appliance. Attempting to login as Admin returns an "you input an invalid password" error.

I've been logging in and out of the server all day with no issue, and I know the password I am using is correct, but still no dice, and the reset password email never arrives when sent so I am unable to reset the password this way.

I still have root access to everything else (SSH, Webmin, PHPMyAdmin, etc), so I'm certain it can be reset through PHPMA, I just don't have the knowledge in which to do so without a little help.

brodie7838's picture

I tried to 'clone' the hash from an existing user's password in PHPMA over to admin's then login with the known text password, but that did not work. I then deleted the admin user, and re-registered a new user with the 'admin' username.

I can now log in as 'admin' but I'm unsure if this is a good resolution or if the default admin user (the one I deleted) had special tie-ins to the Deki Wiki that would have been lost with the deletion of the original. Can anyone confirm?


Alon Swartz's picture

I know you've already solved this, but if anyone else comes across this post I thought I'd add my 2 cents as I'm in the middle of adding inithooks to the 11.0 release to set passwords and other configurations (and had to figure this out).

Mindtouch Core (deki) as well as MediaWiki create the password hash by:

  • hashing the password using md5
  • hashing the hashed password again, but including the USERID and "-" as a prefix

This is what that cryptic explanation looks like in python:

import hashlib
hashpass = hashlib.md5(password).hexdigest()
hashpass = hashlib.md5("1-" + hashpass).hexdigest()     # userid 1

I hope this helps someone...

Liraz Siri's picture

If everything works then your admin account should be real as far as Deki is concerned.

FWIW, we use Deki / AKA MindTouch Core on the TurnKey development wiki. I created an account on it that has Admin privileges and there doesn't seem to be anything I can't do with that account. In other words, if this doesn't work you could try to give special privileges to your new admin account (or any other account). It might require manipulating the database though.

Last time I had a problem the Deki team on IRC were most helpful. You might want to try that. Tell them I said hello and don't forget to come back and share your experience for the benefit of the community!

brodie7838's picture

Liraz:

You're right, creating a new admin account so far seems to be functioning without issue. Thanks for confirming this for me.

 

Kenneth:

From my original post: "I know the password I am using is correct". Hence the " " around "Lost" in the title.


Jeremy Davis's picture

Glad its working out for you.

PS I removed Kenth's post as I'm 99% sure it was spam (his username linked to a website selling password recovery software).

samnewbe's picture

On the website says that the credentials will be set the first bootbut amazon ec2 installation was done automatically, not allowingto set the password for phpmyadmin, webmin and other applications. How do I recover the passwords?

Jeremy Davis's picture

When using AWS your best bet is to launch via the Hub. Then you preseed your passwords there prior to first boot.

If you already have an instance running, then you can (re)initialise passwords and keys etc by running the command:

turnkey-init

Patrick (JINX0101)'s picture

Jeremy, thanks for this posting. This helped me a lot...

Post new comment