Christian Donner's picture
I am trying to install the Shibboleth Apache module in my Drupal 6 VM. There seems to be a problem with one of the dependencies, libxerces-c28. Does anyone have a workaround for me? Thanks.
root@drupal6:/# apt-get install libapache2-mod-shib2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libapache2-mod-shib2: Depends: libsaml2 but it is not going to be installed
                        Depends: libshibsp1 (>= 2.0.dfsg1-4+lenny2) but it is not going to be installed
                        Depends: libxerces-c28 but it is not installable
                        Depends: libxml-security-c14 but it is not going to be installed
                        Depends: libxmltooling1 but it is not going to be installed
E: Broken packages
root@drupal6:/# apt-get install libsaml2            
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libsaml2: Depends: libxerces-c28 but it is not installable
            Depends: libxml-security-c14 but it is not going to be installed
            Depends: libxmltooling1 but it is not going to be installed
E: Broken packages
root@drupal6:/# apt-get install libxerces-c28
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libxerces-c28 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libxerces-c28 has no installation candidate
Forum: 
Jeremy Davis's picture

From what I can see libapache2-mod-shib2 itself isn't even available from the standard repos! Ubuntu 8.04/Hardy (the base of the current stable TKL) repos contain only libapache2-mod-shib. libapache2-mod-shib2  isn't available in the Ubuntu repos until 9.10/Karmic and so will be available in the coming release of (Ubuntu Lucid based) TKL appliances. See the Ubuntu package search for details. So it must be provided from somewhere else - possibly Debian repos or perhaps even the TKL repos themselves?

Ideally I suggest you wait patiently until the next TKL release if you can. If you can't wait, I strongly suggest you backup up everything (give TKLBAM a spin) and do some research and play a bit. You may be able to download the package you need from the Debain repos but I suspect whatever way you go you may run into lots of dramas (commonly reffered to as 'dependancy hell'). Although perhaps you will be lucky?

Liraz or Alon (or some other talented individual) may be able to give you some pointers but I suspect you're on your own with this one (at least until the next TKL release).

Christian Donner's picture

Thanks, JedMeister. I cannot wait and either need to solve this or move to another platform.

Jeremy Davis's picture

If you want to stick with TKL long term, then I would imagine trying to get it running in your current TKL would be the best bet. Although perhaps starting with TKL Core Lucid beta and building your own appliance from there may be better?

I guess it probably depends which is going to b more stable, and migrate cleanest to the official TKL Lucid based Drupal 6 appliance (when it is released). Although I'm not sure how TKLBAM would handle going from TKL Core (with your home rolled version of Drupal 6) to TKL Lucid Drupal 6?

Another factor to consider (and not really sure how Liraz and Alon will handle this either) is that from what I've read, many of the Drupal addons are not compatible with php 5.3 (php version in Lucid) and things work much more nicely under php 5.2 (so better under Karmic/9.10). There are hacks for running 5.2 on Lucid but not sure how keen the TKL guys will be for those. Have to wait and see I guess.

You probably need to make a choice of which way you want to go, make some good backups and go from there. I'm happy to help out if I can but I'm certainly no expert in these things. I just read a lot online so sometimes I sound like I know what I'm talking about :) I have pretty good google fu skills though!

Guest's picture

Have you tried posting to the Shib user's list with your question?  They could probably help you out.

Add new comment