Patrick Snead's picture

I'm new to the Turnkey Linux scene, but I love the idea of the tklbam-backup service.

But I can't get my initial backup to run on either of two new appliances.

I've been able to install the tklbam package, register with the Amazon S3 service, and initialize the tklbam service with my Hub account link.

But when I run tklbam-backup, it throws the following error (identical on both appliances that I'm testing):

Traceback (most recent call last):
  File "/usr/bin/tklbam-backup", line 253, in <module>
  File "/usr/bin/tklbam-backup", line 221, in main
  File "/usr/lib/tklbam/", line 223, in new_backup_record
    response = self._api('POST', 'record/create/', attrs)
  File "/usr/lib/tklbam/", line 180, in _api
    return API.request(method, self.API_URL + uri, attrs, headers)
  File "/usr/lib/tklbam/", line 123, in request
    raise Error(c.response_code, name, description)
hub.Error: (500, 'Piston/0.2.3rc1 (Django 1.2 beta 1) crash report', '\n\nTraceback (most recent call last):\n\n  File "/volatile/hub/apps/backup/api/", line 97, in _inner\n    return func(self, request, **kwargs)\n\n  File "/volatile/hub/apps/backup/api/", line 66, in wrapper\n    return func(self, request, **kwargs)\n\n  File "/volatile/hub/apps/backup/api/", line 193, in create\n    region = lookup_amazonregion(ipaddress)\n\n  File "/volatile/hub/apps/location/", line 34, in lookup_amazonregion\n    return index[location[\'region\']]\n\nKeyError: None\n')

Interestingly, I get the error even when I ask for a simulation to run.

It seems to be an error with the Amazon region lookup, but I'm not sure how to troubleshoot this further.

Any help is appreciated.


Patrick Snead

Jeremy Davis's picture

Then you'll probably need to wait for one of the devs to answer your question. Although you may need to be a little patient as they're full swing working on the next release ATM.

Adrian Moya's picture

To see if that can fix the problem. It does seems for the traceback that is failing looking up your nearest amazon region. Try upgrading all the appliance. 

Alon Swartz's picture

Thanks for reporting the issue. This was the first time we came across the situation that our GeoIP library couldn't pin-point your region (i.e. state) in the US, and so it returned None. We didn't have any code in place to handle such an edge case - but we do now!

Try perform the backup again, all should be well in the world again.

BTW - where is your server located?

Patrick Snead's picture

Fantastic! That fixed it - thanks for your help.

Wow - the backups are very fast - I really like the approach you've taken.

My server is located in Pasadena, MD. Coming from a Comcast Business account in the IP range.

Thanks again.

- Patrick

Add new comment