ejabberd issues

Marc Spafford's picture

I have installed the ejabbered turnkey appliance. Anytime i get to the speeqe page to add a new user, in the Email field, it tells me [u'Invalid characters in username.'] Can anyone help? Attached is a screenshot.

Jeremy Davis's picture

I haven't used that appliance but it certainly seems very strange. I'm assuming that the error relates specifically to the email field (as you say it does and the screenshot suggests that it does also). I'm also assuming that there are no space before or after the email.

Obviously that email address should be accepted going by convention. But have you tried any other combinations to see which character it's complaining about (even if it shouldn't). eg try an email without the "." it may also be worth trying a name without the I have seen some odd systems that don't like the "@" symbol and require you to use a "+" instead, perhaps that is also worth a try?

Marc Spafford's picture

The @ symbol is an issue. But it gives me a different error when i try anything else other than the @ symbol. Look at new screenshot.

Jeremy Davis's picture

Definately seems buggy to me!

Although ... Is this a new install? If so have you run the config script to set the domain? And set up DNS? Not sure if that would create this bug but may be worth a try (if you haven't done it already). Details can be found on the ejabberd Appliance page.

Marc Spafford's picture

So this was a new install and i set all the domain and passwords during install. But it didn't apply them or something, so i ran the scripts and fixed everything. Now i am wondering if the server does message archiving?

Jeremy Davis's picture

But sorry I've no idea. Perhaps worth looking at the documentation for ejabberd and see if/how?

Andrew's picture

I am having the same issues and i don't have a clue what i am doing or how to fix it. Can you Please Walk me through the fix for this? Thanks!

Jeremy Davis's picture

I don't have the eJabberd server handy ATM but I imagine that it's something like:


Hint: you can use the <Tab> key to complete parts of the path, if there are more than one possibility nothing will happen, but you can hit <Tab> a second time to get a list of possibilities.

Datenfalke's picture

I have the same problem with a fresh installation of this turnkex appliance :-( It happens in Firefox and Chromium on Linux. It happens if you put an @ in the email input field.

Jeremy Davis's picture

As per my post above...?

Post new comment