Rich's picture

I've been experimenting with Proxmox VE, and I've installed the Turnkey domain controller (Hardy version) as an OVZ container. Normally I use Virtual box, and after importing the appliance I start it, it shows me the configuration menu, and away I go.

With PVE, it doesn't seem so simple. While it's running, I open the console of the appliance and all I get is:

entered into CT 101



None of the usual useful info.

I didn't know what my IP was, so I did "nano /etc/network/interfaces", and what I found was that was set as my static IP, and my interface is called venet0. During install I set my address as, and the network type as bridged (veth0) so why is it showing the default settings? Under the configuration settings in the web interface is says my IP is unknown...

I tried changing the network settings manually, but since it has some extra settings I'm not familiar with I don't know what to change. I've attached a screenshot of my interfaces file

I'm excited about using the TKLA's in PVE, any suggestions are very much appreciated.

Adrian Moya's picture

That would call the confconsole you are used to. I'd recommend you use a ssh client. If you are on windows use putty. Log in and type confconsole and you'll have your menu. 

I hope this is what you're asking...

Jeremy Davis's picture

Unless you are running a service such as DNS or DHCP that needs access to a physical NIC I would suggest using venet and set the desired IP in the Proxmox UI as you create your new machine. Then you can communicate with your VM via PuTTY (as Adrian suggested) or Shell-in-a-box for commandline access.

Rich's picture

Thanks Jed, I deleted the PDC container and made a new one with venet. This time it worked! I still don't know why it didn't before, since that's the only thing I changed. Something else interesting happened: ssh didn't start with the server. I needed to use "/etc/init.d/ssh restart" for it to show up in "netstat -tulpn"

I'm now able to SSH in, however, I don't know which port the web interface is. When I browse to the IP in http or https with no port specified it says "Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error"

Any idea how to resolve that? If you tell me the port I will browse to that directly.

When I type confconsole while SSH'd in I get:


root@pdc:~# confconsole
-bash: confconsole: command not found

Thanks again.

Jeremy Davis's picture

But its irrelevant because from my experience the only network device confconsole sees under venet is the loopback device (hence probably why the guy who uploaded them removed confconsole). I don't recall whether the PDC worked properly with venet or not, but that shouldn't stop you from being able to communicate with the WebUI components (unless for some reason Samba won't start under venet and that is effecting the other components starting).

I'm really not sure about all the issues you're having and don't have access to my ProxmoxVE machine ATM so can't even have some educated guesses. Regardless, it sounds far from ideal. I've only used a couple of those precreated templates (mostly made my own) and never had any issues. I just liked mine better because I tweaked a few things how I wanted it.

I know it seems complicated but if you follow the directions I put up on the dev wiki then you should find it pretty straight forward. Its basically just a case of installing a TKL appliance (v2009.10-2) into ProxmoxVE (under KVM) and copy-pasting the commands until your done, then finally copying the template out (using SFTP) and you've created your own template! I have uccessfully fcreated an OpenVZ template of the 2009.10 PDC appliance following those instructions and AFAIK the 2009.10-2 update didn't change anything that would break that.

As to your question re ports, you should find eXtplorer on the standard http/https connection (ie ports 80 & 443 respectrively) and the fact you are getting an error doesn't bode well. Perhaps try accessing Webmin to see if thats working: https://<appliance-IP>:12321

If I get a chance in the next few days I will try testing the precreated PDC template so we can compare notes (unless of course you create your own, or get this one working in the meantime).

Rich's picture

Thanks again Jed smiley

Add new comment