Brad Ummer's picture


I'm having trouble getting BIRT ( running and I was hoping for some help. I've searched around a lot to try and resolve my issues, but I can't find anyone else who's installed BIRT onto a TurnKey VM so I though maybe someone on this board might be able to shed some light on the process. I'm generally experienced working on and managing Linux servers, but this is the first time that I've done anything with Java, so I'm trying to get it set up the simplest way I can. I'm using the "Tomcat on Apache" virtual appliance. I had thought that using a VM image would simplify the process, but I'm still running into problems. Let me describe the steps I've taken and the problems I've run into.
- Download and install the VM. This worked fine
- Start the VM. This works fine, and I'm able to SSH into the VM. I'm also able to see the following pages without errors:
(Note, these addresses seem to be different than the default Tomcat addresses, which use a different port- 8080 or 8180. Could this be a problem? Is BIRT looking for something at a specific port?)
- Download BIRT and move WebViewerExample into the Tomcat path, restart Tomcat:
cd /opt/

mkdir download

cd /opt/download



cd birt-runtime-2_6_1

cp -a WebViewerExample /var/lib/tomcat5.5/webapps

mv /var/lib/tomcat5.5/webapps/WebViewerExample/ /var/lib/tomcat5.5/webapps/birt-viewer

- After doing this and viewing the Tomcat Web Application Manager (, I can see /birt-viewer listed under the Applications, but its state is Stop. If I click Start, the Message report:
     FAIL - Application at context path /birt-viewer could not be started
- At this point I started searching around. One thing I found is that when I restarted Tomcat, a bunch of errors got written to /var/log/syslog. The first was:
Nov 27 03:53:52 tomcat-apache jsvc.exec[9634]: Nov 27, 2010 3:53:52 AM org.apache.catalina.core.StandardContext listenerStart SEVERE: Exception sending context initialized event to listener instance of class access denied (java.util.PropertyPermission birt.designer read) ^Iat ^Iat ^Iat java.lang.SecurityManager.checkPermission( ^Iat java.lang.SecurityManager.checkPropertyAccess( ^Iat java.lang.System.getProperty( ^Iat ^Iat ^Iat org.apache.catalina.core.StandardContext.listenerStart(StandardCont

Searching for this error lead me to posts that pointed to TOMCAT5_SECURITY. Following those instructions, I found that if I disable TOMCAT5_SECURITY (by setting TOMCAT5_SECURITY=no in /etc/default/tomcat5.5) and restart Tomcat, then the error goes away and Application Manager page shows birt-viewer as running. So that's good. But if I click on the /birt-viewer link to open the page (, I get a 404. So that's bad. So my first question is, is disabling TOMCAT5_SECURITY a requirement to get BIRT running, or is it indicative of a different problem with my installation? For example, is this the result of something else that I don't have set up correctly (like bad permissions on something)? I've tried chmod'ing everything in birt-viewer to 777 but that didn't help. Also, I don't know anything about TOMCAT5_SECURITY, but the config file says not to disable it unless you know what you're doing, which I don't.
My obvious second question is, why does the Web Application Manager say that birt-viewer is running, but the application page returns a 404? Is it really running and I just can't see the page, or is it not really running?
Once I get this all figured out I'd like to write up a how-to, since this seems like using a TurnKey VM should be a nice quick way to get BIRT up and running. Thanks for any help you can provide in resolving my issues.
Brad Ummer's picture


I just tried starting from scratch using the newer TurnKey VM (the RC version) that contains the following:
Apache Tomcat/6.0.24
JVM Version 1.6.0_20-b20
and now I can start Tomcat without the errors (without having to disable any security features) and with birt-viewer showing as running in the Application Manager page, so I'm making progress. Here's a screenshot of the page:
However I still can't see the birt-viewer page (I get a 404). One thing I'm thinking it might be is the port that Tomcat is using. On the TurnKey VM, it is set up to use port 80, not 8080. So the Application Manager page is:
(Note is the IP of the VM on my box) If I try to access it via any other ports (e.g., it can't connect to the server, so I'm guessing that birt-viewer needs to be accessed via 80 as well. But going to this link:
gives me the 404. Note I've also installed the commons logging library using:
cd /opt/download
cp /opt/download/commons-logging-1.1.1/commons-logging-1.1.1.jar /var/lib/tomcat6/webapps/birt-viewer/WEB-INF/lib/
/etc/init.d/tomcat6 restart
Here's what I’m seeing in the log files:
root@tomcat-apache log/apache2# tail -n1 /var/log/apache2/error.log
[Mon Dec 06 02:19:46 2010] [error] [client] File does not exist: /var/www/birt-viewer, referer:

root@tomcat-apache log/apache2# tail -n1 /var/log/apache2/other_vhosts_access.log - - [06/Dec/2010:02:32:02 +0000] "GET /birt-viewer HTTP/1.1" 404 503 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_5; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4"
Could it be that birt-viewer is hard-wired to run at a port other than 80? Are there any other things I could look at to figure out what's going wrong (like other logs)? Thanks for any help.

Add new comment