Neal Babcock's picture

I have been using this Wordpress appliance for about a year. Recently, after I rebooted the appliance I got an error message saying "Inode 776158 has illegal blocks".

I tried running fsck manually, but had no luck.

I have attached a screenshot.

Any tips or advice would be appreciated.


Jeremy Davis's picture

I would expect fsck to either work or error and hopefully give you some idea of why.

Can you run

fsck /dev/sda1

from the maintenance shell. Perhaps post another screenshot of what happens. Attach it to your first post.

Neal Babcock's picture


Thanks for your reply.
I ran fsck /dev/sda1. The result is the same as when I simply ran fsck before.
I am prompted to clear all the errors. When I do (there must be 40), it clears all the errors, but when I reboot the appliance and look at the site in my browser, all the posts are gone.
I have attached a new screenshot to the first post.

Jeremy Davis's picture

Not really sure... From your screenshots looks like you're using VMware (I assume with a virtual hdd). I haven't encountered that sort of issue before.

Just to let me get this straight, fsck works and solves the problem but you lose lots of data? Or does it just say it works and same problem next time.

If your losing data perhaps you may be able to find the missing data (or some of it at least) in the /lost+found folder.

Either way perhaps you could try mounting the virtual disk as a secondary drive to another VM (I assume you can do thaat with VMware). Hopefully you can rescue your data and transfer it to a clean install. I'm not sure how you go about dumping a dead database though?

It may be worth doing a fsck/chdsk on the physical HDD too that the virtual one resides on.

Add new comment