Forum: 

Your Amazon EC2 account is not enabled for TurnKey Linux deployment.

David Killingsworth's picture

When I try to launch an appliance at hub.turnkeylinux.org, I get the message "Youur Amazon EC2 account is not enabled for TurnKey Linux deployment."

I then login to Amazon and authorize the subscription.

Then I go back to launching an appliance, and I get the same message.

It's an endless cycle.

 

Is there something wrong with the system?

Alon Swartz's picture

Something is wrong with Amazon Devpay which is causing the outage. US-West-1 and EU-West-1 are currently not allowing instances to be launched, for anyone. But, it seems US-East-1 is working at the moment though.

We are in contact with the Amazon DevPay and are waiting for them to fix the issue.

I'll update this forum post as soon as I have an update. Sorry about this folks.

[update] AWS got back to us and said that they had an issue with the devpay pipeline. They requested we update the TurnKey Devpay product with some new settings, which we have just done. They now need to activate the changes and it should solve the problem.

[update] AWS have activated the changes and it solves the problem. All regions are working as expected.

Rick's picture

I think this is happening again.  I am not able to launch instances in Western Europe.

 

Thanks,

Rick

Ricky's picture

It happened to me too.

Ricky

Alon Swartz's picture

It seems to be a different issue, but results in the same error message returned from the Amazon API.

We identified the issue and it should be fixed (as soon as changes take effect). For more information see my comment here.

Ricky's picture

Thanks for the support!

Ricky

Stephen Sper's picture

I'm also receiving the message "Your Amazon EC2 account is not enabled for TurnKey Linux deployment."

I've logged into Amazon and authorized the subscription. After going back to launch an application, I get the same message.

Thanks.

Jeremy Davis's picture

And it seems that there is an authentication issue. The most common reason is that the signup process isn't quite complete...

Amazon changed things a little while ago and a number of users have had issues. We've tried to make the documentation/help as straight forward as possible but it's possibly not quite where it needs to be just yet...

Can you please try this:

From the Amazon DevPay page (you'll need to login with your AWS credentials) and click the link next to "TurnKey Linux on EC2" titled "Go to Application". After that check in the Hub here (logged in with Hub credentials) and your plan should show.

Hopefully you'll be good to go now... If not please let us know and we'll dig a little deeper.

Post new comment