appel's picture

Just discovered this distribution and so far absolutely love it. It works very well on my macbook whenever there's a network. But what if there's no internet connection? Would I still be able to reach it? Excuse me if I'm overlooking something completely obvious!

Jeremy Davis's picture

But you do obviously need a network path from the PC you're working on to the LAMP appliance. Internet is only required for updates, installation of apps and backups with TKLBAM.

Dan Robertson's picture

If you are running this in a virtual machine, there are three different types of networking you can use.  Bridged, NAT, and Host Only.  Bridged means it gets its own IP address, NAT means it piggybacks off of your computer's IP and Host Only means it can only communicate with your computer.  If you don't have a network connection, you would still be able to access the virtual machine if it is set to NAT or Host Only.

appel's picture

Thank you for your replies, I got it to work in host-only mode, which is perfect for my needs!

reaz's picture

Is there any network configuration needed in the host side ( eg. like assigning an Ip address to a physical wired network).I tried the guest ip ( in this case https:// # ) in my browser in host but it doesn't connect.

appel's picture

Did you set up port forwarding rules under the network tab of Virtualbox' settings?

reaz's picture

I have seen that option, I Will try that later - but isn't this supposed to work without much configuration, at least thats what TKL claims.

But I have gone through the virtualbox installation routine of the LAMP iso as described here in TKL  documentation.It says  configure the network as bridge connection before the iso installtion.But after first booting I don't get the preconfigured IP , rather there is a message "network is not yet configured".It is not possible to configure it manually from there , there is some bug in the manual configuration  -  I can set the IP address but cann't go to next line,cann't set the mask ,gateway etc.

Thanks for the reply though.

Liraz Siri's picture

With a local deployment you have to take care of the local hardware, the local network, the virtualization software that has to be properly configured with it all. TurnKey only comes in after you've set all of that up properly.

If you're having troubles setting up TurnKey locally try using the TurnKey Hub to deploy appliances on demand on Amazon EC2. You won't have any networking issues because the Hub pre-configures the network for you.

But if you're going to deploy appliances on local hardware, you're going to have to accept more responsibility because though TurnKey may require minimal configuration at the appliance level, there's not much we can do regarding the configuration required by your virtualization software, besides maybe trying to improve the documentation.

If VirtualBox is too difficult for you to setup, maybe you could try VMWare Player.

One day, we may try bundling TurnKey together with pre-configured virtualization software so we get closer to providing end-users with the entire solution on local hardware, but even then you may still run into hardware and networking problems.

Jeremy Davis's picture

In the network settings of ConfConsole you should be able to go to the next line by using the down arrow. If that doesn't work then it would suggest to me some serious VBox config issues. Are you use a standard US keyboard?

As for VBox NAT setup, if you use NAT you will need to configure it. If you want external access then use "Bridged" if you only want access from the host machine only (as the OP requested) then use "host only". Explanation of the options is available here.

But unless you don't have a DHCP server running in your network (which would be uncommon as most consumer grade modem/routers do this by default) then your issue ("network not yet configured") is probably related to networking issues.

A couple of questions/suggestions for troubleshooting:

  • Did you select an alternative virtual NIC during install of TKL? The default VBox vNIC should work OOTB.
  • Have you double checked that you have the correct networking option? Ie "bridged". I have had problems in the past with VBox and have found that setting networking to something else, booting, then stopping VM and changing it back to "Bridged" has worked for me (some bug in VBox - although I haven't had those sort of problems since I've been using Ubuntu rather than Windows but maybe that's coincidental).
reaz's picture

Thanks a lot Liraz and Jeremy.You have pretty much addressed all the issues(and the mistakes I made).Since I am using the latest version of Vbox there might be some problem with settings ( or not - working on it).Thanks again.

reaz's picture

Yes up & running.Kudos to Jeremy for resolving the conflicting issues.Thanks a lot.

Monte Milanuk's picture

What seems to work for me is to set the LAMP appliance up with two network adapters inside Virtualbox (using latest version, also running on a Macbook).

The first is set up as a host-only, so it gets an address from VBox's built in NAT that looks something like ''.  That is the interface that all the ports that the appliance offers - ssh, http/https, the webmin interface, shell-in-a-box, phpmyadmin, etc. are offered up on.

The other interface is set up via regular Vbox NAT (the default connection type).  It gets its address from the NAT dhcp server, something like '' or whatever, but really all this interface is for is to get updates.  When the virtual machine is up and the laptop is connected, I can run 'apt-get update && apt-get upgrade' and it'll automagically get the updates via its NAT'd connection.  The rest of the time, even when the laptop isn't connected, I can still connect to it via the 'host-only' net using ssh, https, etc.



Jeremy Davis's picture

Thanks for sharing. :)

Add new comment