First of all thanks a lot for this awesome platform, I've just started to play with turnkeylinux since 1-2 weeks ago and like it very much. Great time saving!

Here is my question. Currently I have a drupal 6 appliance (11.1) running in ESXi host, I can not run 'sudo' command. I get this error: "bash: sudo: command not found". Please advice how to enable/install sudo/sudoers.

I understand that with original setup, the default login is already root account. But I want to create a normal account (non priviledged) for all of my development tasks with drupal. only when needed, I'd want to use 'sudo' for administrative tasks.

PS: I've noticed that some other posts in this forum advice to use sudo command. It is that sudo was available with older turnkeylinux core version and just remove recently?

Thanks in advance.


I found this helps:

1. Log in as root

2. apt-get update

3. apt-get install sudo

Let us know if this solves it for you as well.

I can't remember what group to add your user to make sudo available; I think it's sudo.

Thank you very much for your response.

It works! Now I can use sudo command.

But the system seems to delay about 10s before the command executed. I tried the very simple command: 'sudo ls /etc' and it just stop there for about 10s then output the folder content. I'm not sure if it's because I run this appliance in a virtual machine?!?

I think it must be something wrong, but at least it works now.


Jeremy Davis's picture

No sudo by default. I answered the question on askubuntu in more detail. But bottomline is if you want to use it, just install it.

Add new comment