Jared's picture

I managed to fix this, so I don't need a resolution, but it is something that seems to have been out-of-whack on a fresh Turnkey install, so I thought I should report it.

I downloaded the vmdk version of the Drupal6 appliance.  I extracted the vmdk from the zip file, created an Ubuntu machine in VirtualBox, and pointed it at the vmdk.  It booted up just fine and I was able to surf to the initial setup page where it asks you for admin account details, admin email, etc.

That seemed to go ok, but when it was finished, all attempts to surf to the default page would always redirect to to install.php.  I could successfully get to other locations such as /admin, /user, /index.php, etc.  But when I just put the host address in my browser bar with no further directories or documents (i.e., the "root" directory of the web site), it would always go to install.php.

After a couple hours of poking around, I discovered that there was a file in /usr/share/drupal6/tmp called "redirect_install.php".  It contained one line which contained php code to redirect to install.php.

I removed that file and now it works fine. 

I couldn't find any info on this file at all online.  Plugging in the exact filename into Google turned up only one hit, and it was to a discussion thread here at the TurnkeyLinux site from about a year ago concerning a previous version.  The person who mentioned it seems to have encountered a similar thing, but under different circumstances (he was doing something more advanced than what I was doing: I was just turning up a fresh install for the first time). 

I fixed it, so I'm good to go, but wanted to pass along in case there's a way to prevent others having to deal with this.

For the record, my configuration is: VirtualBox running on a Windows XP host; guest machine configured with "Host-Only" adapter.  This is a test/learning/development machine that is not intended to ever go out on the real network, and does not have any domain name or host name attached to it--it is just referenced by IP number for now.

I've used Turnkey Drupal6 before, with no issue, but this is the first time with the version 11.1 appliance, which apparently only came out a couple weeks ago.

Liraz Siri's picture

I just reproduced this. We'll have to investigate how this slipped through testing. Since it's a showstopper, we'll have to fix this soon. In the meantime I've added a workaround to the appliance documentation.
Liraz Siri's picture

Further investigation shows that it is likely that a recent Ubuntu security update is the cause for this breakage. Argh!
CJack's picture


Above you said you provided a workaround ... where is that information please?

Jared's picture

CJack, on the main page for the Drupal appliance, look under "Known Issues."  Directly under it, Liraz posted the following command which you would execute from the console of your TKL Drupal server:

rm -f /usr/share/drupal6/tmp/install_redirect.php

Add new comment