Guest's picture
Hello I just loaded the turnkey-ejabberd-11.1-lucid-x86-ovf into my VMWare Host and went through the initial setup. However I am having troubles creating a new chat room via the address or All I get is Internet Explorer cannot display the webpage". What did I miss in the install? I even added an entry in the hosts file(/etc/hosts : appliance_ip Thank you in advance for any help on this.
Guest's picture


Jeremy Davis's picture

Looks like this post slipped through the cracks, so sorry about that.

I'm guessing that you either resolved it or gave up by now. But just in case you didn't, the first thing I'd check is networking. Make sure you are using either "host only" or "bridged" networking for your VM and also check the appliance IP from the config console screen (the blue screen that should display on boot of your appliance).

Beyond that I'm probably not much help but if you want any further guidance I'm happy to try so please post back.

Alon Swartz's picture

IIRC, you need to browse to the server using the FQDN (Fully Qualified Domain Name), for example:

I updated the appliance page with some more information regarding chat.XMPP_DOMAIN and notes on connecting to the server with pidgin.

Michel's picture


I just loaded the turnkey ejabber into VMWARe and I have trouble as user try to create their own account from the speeqe web page.

The page require an email address to be specified and when the email address is specified correctly I have the following error message :


[u'Invalid characters in username.']

Nathan Wienand's picture

Added new comment by accident - :)

Good luck. :)

Nathan Wienand's picture

I finally figured out the issue, the issue is that speeqe's account registration code cannot correcltly deal with the deailt MATCH_BAD_WORDS[''] and EXACT_BAD_WORDS[''] array's which both default to one empty string entry... put a bad word in there and the issue is resolved.

Alternately you can hack the /var/www/django/speeqeweb/speeqe/ file and comment out the 4 lines that scan for exact word matches in the username field.

Option A is by far the easiest, just "nano /etc/speeqe/" and add the word, perhaps Turnkey will update the default for us in the next release. 

(keep up the good work guys, and thanks :) )

You WILL need to restart apache for it to take effect.

If anyone can help me figure out why speeqe's new account's don't register as new JID's ... would love to hear from you... that one is killing me.

Nathan Wienand's picture

New speeqe account's will appear to work but logging out and back in will show the issue.

The speeqe accounts are separate from eJabberD, and no actual user accounts are created on the server, i think this is abug in speeqe. Speeqe has the accounts logged in it's configured DB (sqlite3 by default). So you cannot recreate the same user and logging in to speeqe will work the first time, and so will joining a room after you create the account, but the account is not registered with jabber properly so you'll get dropped as soon as you try join a room on subsequent logins...

Kinda sucky, trying to figure it out.

Any ideas/solutions to this - let me know pls.


pete's picture

hi guys not sure if this is the right place to post but can anyone tell me if the jabber/speeqe appliance will fit into an amazon microsite and if so how many concurrent users it will serve or point me to somewhere where i can get the answer?



Jeremy Davis's picture

But ultimately it will depend on how much load you put on it (ie how many connections etc). I have no idea how you would find out other than trial and error, although you could try researching/searching/asking on the relevant (jabber/speeqe) forum(s)/mailing list(s)/web sites (or even just having a good google around). You could always try it and if it doesn't work then you could migrate it to a larger instance. TKLBAM makes migration between different size instances easy.

Another option may be to download the ISO or VM image and install to a VM with similar specs to a micro instance and check it out that way.

pete's picture

Thanks very much for the prompt reply. I've dug around quite a bit already but to no avail. I will try the VM deployment in the micro instance.


Add new comment