Cody L's picture

First, I would like to apologize for my long rambling story. I have been using the Turnkey Wordpress Appliance for almost a year now, and it has been great. Recently, I decided to install vlc-shares ( to complement the jinzora installation I have been using along with wordpress. Somehow, after installing the required zend-framework, zend-framework-bin, php5-cli, php5-sqlite, and vlc, apache would not restart. After checking the log (var\log\apache2\error.log), which returned only the non-fatal error "Could not reliably determine the server's fully qualified domain name, using for ServerName", and trying several fixes proposed on forums, I decided to reformat and reinstall Turnkey.

I began by downloading the newest version of the Wordpress Appliance (ver. 11.1, the .iso) and burning it to a disc. After booting to the disc, i selected the option to install. It scrolled through some lines and then the screen went blank for more than 20 minutes. I was able to eventually determine that it hit some sort of driver error (I think, it was hard to see), after trying multiple discs and image mirrors, I decided to use an older version of the appliance i had lying around, based on Hardy. Installation went fine, and I was able to install the xubuntu-desktop (just in case webmin wasn't available). Everything was still working fine at this point.

I then tried to install vlc-shares again (note I haven't actually been able to get to the point of actually installing it, only the dependencies listed above), and vlc wouldn't install because it required newer versions of packages than are available in the Hardy repos. So I tried to do a dist-upgrade (first with webmin, then with synaptic after another reformat). Both times, webmin became not reachable after the upgrade to 10.04. Finally, I tried manually deselecting all webmin associated packages and doing the upgrade, and everything was fine. So something between webmin and 10.04 does not get along on my machine. By the way, this is a Dell Dimension 8300, and Turnkey is the only OS on the box.

So getting using an older version of webmin seems to have fixed my problem in that sense, but I still have the problem that apache refuses to start as soon as I install the packages in the first paragraph. I have tried modifying apache2.conf, httpd.conf, and ports.conf, to no success.

So my (long winded) question(s) are this: can anyone tell me why installing those packeges might break apache, and what I might do to fix it. Also, does anyone know why the newest version of webmin doesn't play nice with my machine? And, finally, is it possible that the 10.xx versions of ubuntu shipped with a kernel that removed or replaced some necessary driver making it unable to be installed on my machine? I am fairly computer literate, but I am still new to *nix, so I would appreciate any suggestions, as I have been pulling my hair out for a few days on this.

Thanks in advance

Don Sanderson's picture

Without going through all the pain of figuring out why the older version of the appliance won't work.

I suggest using the 11.1 version of TurnKey and adding whatever 'boot option' is needed to get your video working from the CD install.

There are many articles about this via Google.

Here are just a couple:

Add new comment