Scott Howard's picture

Hi Guys.

Have decided to try the cloud server feature from Turnkey Hub. I have an Amazon EC2 account. Logged in , found the access keys section, copied and pasted them to the hub page, and clicked the ADD button, and all I get is an exclamation mark icon at the top of the page which provides no information.

Generated a new access key and secret key, tried the same with these and still only the exclamation mark icon ????


Can anyone enlighten me as to what I am doing wrong, and what is this seemingly useless exclamation mark icon all about ? .... an explanation of the error would be more helpful.


Thanks in anticipation.


Scott H.

Jeremy Davis's picture

It's been a while since I set mine up, but I vaguely recall that I may have had a similar problem initially. I think when you set up your Amazon account it can take a little while for it to all get processed (or maybe there was something I was doing wrong...? I don't really recall), so perhaps just try again soon. If that doesn't work, I'd advise you to use the feedback feature of the hub, as that will get the attention of the devs quicker than a post here. Also the feedback will be linked to your hub account so they can double check what the problem may be.

Scott Howard's picture

Turns out I read things wrong. (again....)

I thought having an AWS account meant I had an EC2 account ... but it doesnt !

You have to sign up for one at Amazon (just like it says in the instructions funnily enough).

The exclamation mark icon is in the notification area at top right of the hub dashboard... as I said to Alon  it still would be nice to have a message with the icon to indicate the error description .. but I suppose it is difficult to trap and handle every eventuality .

Anyway , once signed up for EC2 everything worked as it was supposed to... now onto solving these Zimbra issues....


Scott H.

Jeremy Davis's picture

I did exactly the same thing and IIRC correctly Alon modified the help to try to make that clearer. Obviously still not clear enough :p ! Glad you got it sorted.

Add new comment