can't init tklbam

ilmasce's picture
I've subscribed the tkl hub account but when I try to issue the tklbam-init command I get the error: (7, "couldn't connect to host"). This happens in the initialization web form too. I'm behind a proxy that's been configured in both firefox (through Edit->Preferences->Configure how firefox connects to the internet) and Ubuntu (through export http_proxy). Fabio
ilmasce's picture

Thanks to a 5 minutes fast and self-taught course on Python debugging I've seen the error is given by the method API.request in hub.py (line 187) called by method hub.Backups.get_sub_apikey(apikey) in cmd_init.py (line 106)

API.request passed parameters are:

('GET', https://hub.turnkeylinux.org/api/backup/subkey/ , {'apikey':<my apikey>}, {'Accept':'application/json'})

However if I try to paste the address on the browser's url I get the following error:

Request.MissingArgument:Required argument: apikey

the address seems correct and working...so why that error?

ilmasce's picture

Ok, I've found it...it was my fault : didn'd specify proxy settings for https but only for http.

After I've exported also https_proxy all has gone good. :)

Tanks,

Fabio

Alon Swartz's picture

But I'm glad you found and fixed the issue. Could you post details of your proxy configuration for others users who have a similar setup?

ilmasce's picture

Ok, I simply modified the file /etc/bash.bashrc adding the following line

export https_proxy=https://<my proxy's IP>:<port>/

and this did the trick!

Fabio

Post new comment