After converting my Joomla appliance from VirtualBox to VMWare esxi 4.1, I noticed that vmware-tools was reported as "not installed" by my vSphere client. Here is what I've done thus far.

- Installed kernel headers and compiler using apt-get.

- unpacked vmware-tools from the tarball, ran and chose the default options. It seemed to complete successfully. vSphere still shows "not installed" after rebooting and the vmware-user process was not running.

- After all that, I learned that Joomla comes with an optimized vmware-tools pre-installed so I removed the version I installed using the uninstall script provided and attempted to install vmware-tools using apt-get. It seemed to install without any problems but still the vmware-user process was not running and vSphere still reported "not installed".

Questions: How can i fix this without deploying a new Joomla appliance and configuring it from scratch? Is there a turnkey repository I can pull an optimized vmware-tools version from using apt-get? Is there any trick to getting a compiled vmware-tools working on the Joompla appliance? Interesting note: Installing from the tarball worked great on my turnkey lamp appliance. Thank you for reading.

Liraz Siri's picture

I recommend you try backing up your system with TKLBAM and then restoring the backup to a clean TurnKey Joomla installation.

I tried to do a local backup using tklbam but found that I need to have an account with amazon s3 tied to my turnkey hub account.  This is absurd.  I just want a local backup and I shouldn't have to sign up for cloud storage just to do a local backup.  It feels like turnkey and amazon are shaking me down.

Jeremy Davis's picture

I agree that it would be nice to just be able to do local (or even remote to a cloud provider of your choice) backups without having to sign up for AWS. And I know that support for other providers is on the todo list. But unfortunately there isn't an open API that works across the board with all providers (wouldn't that be nice!) so the practicalities of doing that is pretty huge.

I can't speak for the core devs but from where I sit they are trying to make a robust, production ready product that is available to all, basically for free. I'm not 100% sure why you need an AWS account to make it all work but I know in it's current setup the Hub is closely tied to Amazon. For all it's faults AWS is robust and enterprise ready with datacentres all over the world making it an ideal basis for this type of thing.

And I can 110% vouch for the integrity of Alon and Liraz (although not Amazon) and can tell you from experience that you will not be charged a cent if you don't use AWS. Although I can't guarantee that once you have it set up and see how easy, reliable and powerful the tools that TKL make available via AWS you may end up spending a few cents... (I think over the years I have been involved here I have nearly spent a couple of dollars I reckon!) Speaking from experience, if you only do local backups and don't launch any AWS instances you will get a an Amazon account for $0.00 I know when the TKL guys first launched TKLBAM there were many users worried because they were getting bills for $0.00 and were wondering where the catch was. No catch, just AWS charge by the GB so if your back up is only a few hundred MB then no charge... If you don't use AWS at all and get charged then I'm sure Alon and/or Liraz would help you sort it out with them.

Installing "open-vm-tools" from the Ubuntu multiverse repository worked okay.  vSphere reports vmware tools status as "unmanaged", but that's fine for my purposes.  I only need vSphere to shut down the guest.

Add new comment