Recently (last couple of weeks) downloaded the Gallery Appliance as a VM machine. Worked well and have uploaded many photographs. On the point of going live when the site can suddenly no longer be accessed. "Error" is the only message displayed when trying to access main.php in a web browser.

Haven't made any changes to cause this. Linux VM machine boots ok, no apparent error messages. Possible that mysql is not loading as cannot stop-start this server.

Jeremy Davis's picture

If not then probably a good idea next time... If you do, probably the easiest thing would be to restore to a new VM.

Otherwise, I have no idea really, but perhaps an auto update has broken something? It shouldn't have, but you never know... You can run the security updates again manually (hopefully anything that was broken has been fixed, usually if security updates are broken they do get fixed very quickly).


If that doesn't work you could try doing a complete upgrade:

apt-get update && apt-get upgrade

If that doesn't work then I haven't got any bright ideas. I'm sure that there would be other troubleshooting you can do but I'm not sure where to start really. I'd be inclined to start again (with backups this time - TKLBAM is a winner) as it may take longer to troubleshoot and repair than starting again.

Sorry I can't help you more. I know this sort of thing is really frustrating, but in my experince with TKL, this only happens very rarely (and is not too big a deal if you have a good backup, such as TKLBAM).

Hi Jeremy, many thanks for your response, very much appreciated.

Backup - no I'm afraid. This started as an experiment and we were making good progress so were moving towards going live. Backups were on the list of the next things to look at. I skipped over the TKLBAM at install thinking "I'll look at that later". Might change that to look at that now.

I came to a similar conclusion as yourself last night that perhaps the automatic updates had broken something. It appears to be the mysql database - the service will not start despite much prompting.

I have worked out where the database and photographs are kept in Gallery2, so it is not a total loss, and it may well be quicker to setup another VM and re-import. Also I don't want to attempt a fix such as running another update and make things worse.

Thanks for your help and I'll definately look at the TKLBAM backup this time. I'll let you know if I manage to fix the original problem.



Windows Shadow Copy came to the rescue. We had hosted the Turnkey Linux virtual machine using VM Player on a Windows 2003 server running Shadow Copy. We were able to recover an instance of the virtual machine from about a week ago and are back up and running.

Will have a look at TKLBAM also as you suggest.


Jeremy Davis's picture

Nice work. Yeah I definately recommend you check out TKLBAM.

Add new comment