ryan roberts's picture

Hello All,

I have an unusual problem, I had TKL file server installed and working fine with no issues on SBS (small business server) 2011 Essentials Beta (through connect.microsoft.com) and just now got the final version from a retailer..So I had to reinstall the server, I setup the server in the same way as before, Same name, Same Domain, Same users, same everything, and the TKL file server was not being seen on the server.

So I logged into TKL file server box and did another "bind to domain", I did not change any settings on the box, and the TKL file server is still not being seen on the server...Help! I don't know what happened or why the TKL is not being seen now, when nothing has changed for Domain, Users, Server name, etc...I don't know where to go or start with this issue...


Thank you in advance for everyone who responds.

Jeremy Davis's picture

Because of the way Win products create unique (and random) SIDs for machines and users on install/creation, despite you configuring it similarly, really it is a completely new setup. It is also quite possible that there are some minor config procedures you have forgotten to replicate or done slightly differently.

The only way you could have created something that is 'exactly' the same would be to add your new server to your domain alongside you original beta machine, then transfer the master server role (forget what MS call that exactly) to the new server and remove the old one. Beyond the fact that you probably aren't able to do that because of the limitations of SBS and/or a beta MS products I would've thought what you have done should still work.

So I'd start at the start and ensure that there isn't any networking issues between the machines (can they ping each other?) If you are using machine names, are the correct entries in DNS on the MS server?

TBH Samba3 (as used on TKL appliances) domain stuff is pretty old (complient with NT/2K domains) and so there may some limitations introduced into the MS product since the beta (perhaps some 'security' enhancements, reduction in legacy support, etc?)

So bottom line is IMO it should still work and I have no idea why not. Logic suggests that in theory it should still work fine, but this is an MS product we're talking about :p. Sorry, just joking. There are so many potential factors that may be causing your problems. Sorry I can't be of more practical help, but I have no knowledge of MS server products since 2k3. Since my migration away from MS products I haven't had any need or interest in keeping up with new developments.

TomW's picture

Hi Ryan.  I just installed WHS 2011 and I have been trying to fig that out too.  I want to attach my centos 5 and debian 6 pc's to the server which is based on win 2008 R2 (same as SBS 2011).  I tried using just straight smbclient and it sees the server shares but authentication is the snag I believe.  I am going to look into setting up NFS Services on WHS I suppose as I do want to use the WHS as storage for the linux clients I have.  If you solve this please share the steps to connect and I'll do the same.  Not much on google for this yet except full blown Samba <--> PDC-LDAP-Kerberos user integration stuff which is overkill for a small lan imo. If that was straighforward I'd have done it already but it's alot of smb.conf editing-testing.

I'm looking for simple user based share access basically. 

ryan roberts's picture

Ok, so i have an update on the issue...By restarting the Linux box and the Server, I was able to get the server to see the linux box but not I can not get the Auth correct...I have deleted the user accounts and remade them on the linux box (i deleted the accounts i made when i was running the Beta code for SBS Essentials 2011) then rejoined the linux box to the domain, but this did not work...I can see the share but i can't access it...

Any Idea's?

Jeremy Davis's picture

Rereading this thread, I recall reading on here somewhere a post where someone else (I think it may have been Chris Musty but could be wrong) was having a similar problem with a recent Win Server product and I'm sure he posted a smb.conf which would work (but then Samba required no authentication at all, which may or may not be useful). But I've just had a search and can't find it... :(

I also vaguely recall reading somewhere that a registry hack was needed to acheive this. Actually, now I think about it, perhaps that was to get a Win 7 machine to connect to a Samba3 DC? So perhaps that is heading you in the wrong direction...?

And as a 3rd remotely possible sidetrack, this thread might be worth a quick scan. It's actually talkoing about using Win AD user accounts to log into Samba (which may or may not work and/or resolve your issue).

Also seeing as you have recreated Linux users, one other thing (which you have probably already checked, but just to be complete), make sure that the Linux user file permissions match the Samba share permissions (and that Linux and Samba users are synced). I have overlooked this myself in the past, it's easy to do. (Same as Win shares there are both share and file permissions).

Add new comment