L. Arnold's picture

See Solution in bottom Reply:  Lots of try's on a slow process.


I have been working through a TKLBAM-restore and having gotten a few limits to work I got further down the MYSQL list in Magento and got a different Pipe Broken situation.

TABLE: magento/sales_flat_quote
ERROR 2013 (HY000) at line 20889: Lost Connection to MYSQL Server during Query
Traceback (most recent call last):
    File "/usr/bin/tklbam-restore", line 313, in <module>
    File "/usr/bin/tklam-restore", line 301,in main
    File"/usr/lib/tklbam/restore.pq", line 106, in database
    File "/usr/lib/tklbam/myslq.py", line 402, in restore
     &nb sp;  fs2mysql(mysql(), myfs, **kws)
    File "/usr/lib/tklbam/mysql.py",line365, in fs2mysql
        MyFS_Reader(myfs, limits, skip_extended_insert, add_drop_database).tofile(fh,callback)
... 3 more lines
IOError: {Errno32} Broken Pipe


Any ideas on how to proceed with this?

thank you,

L. Arnold

L. Arnold's picture

I just tried this to a 11.2 Appliance rather than ISO build.

Previously I was using an ISO install and I noted that I was getting "Casper Errors" during install.  I don't know what those refer to.

I did "again" increase my max_allowed _packet to 300mb (temporarily)  and I did exclude one MYSQL file catalogsearch_query that had caused earlier max_allowed_packet issues.

It seems that My TKLBAM-RESTORE command restored my Databases but Not My Files this time.

I am reading somehow that SUBVERSION is being interpreted in 11.2 and it might not be Loading those entities (which is basically all the files I do need loaded)...  So, Trying again with a "straight, non limited TKLBAM-RESTORE command right over the same build... 

Lets see what happens.    This does take forever.  (Also trying this to a TKLAPP instance which is also taking forever.

Just did a non --limits Restore and got the Same Error as in the first post, but this time to a different MYSQL file (so I have seen this now on at least 3 MySQL Files).

I would really like to stop burning this Bandwidth.


Next strategy is to do a Restore of Just Databases and another of Just Files.  We will see how that goes.

L. Arnold's picture

After --skip-files and --skip-packages (trying simply to backup MYSQL files) I get the error:

download ... diftar.gpg failed (attempt 1, reason SSL Error

attempt 2,  Reason Incomplete Read ... through to attempt... 5)

Backend exception...  difftar17.gpg

WebShell basically goes blank.  Not sure if it is proceeding from here.


meanwhile tklapp.com has taken 5 hours now to install the same backup.  It seems to think it is still working on this.  Console does not show any information other than tklbam-restore has started.

How to proceed?

L. Arnold's picture

I found Jeremy's post on this forum thread:

That encouraged me to

apt-get --purge remove tklbam

followed by

apt-get install tklbam

Then tklbam-restore (BU#) --time --skip-files --skip-packages

and my Data Files (in this case) took.  On a separate attempt they did not, but am trying to fix the same way having applied a max_allowed_packet update as outlined on this thread.

Now its Magento time.

L. Arnold's picture

If a TKLBAM-Restore is taking place and the WEBSHELL session closes before completion is the process aborted or does it continue?

It seems I just got a functional restore by running in a series of these steps.

Install VM (application not from ISO)



Open WebShell

Increase max_allowed_packets in WEBSHELL (mysql command)

Issue TKLBAM-RESTORE (last full backup) --skip-files --skip-packages

Issue TKL-BAM-RESTORE (last full backup) --skip-database

WebSHell closed a bit early when (chown) was still being set

Restart Apache in WEBMIN

Run Magento Cleanup  (should apply the correct chown, but may have issues in SVN)..  I may have issues.??

(SITE Shows UP after 3 days)  Yes.

Add new comment