TurnKey Linux Virtual Appliance Library

accessing Webmin -- LAMP

Feeling kinda dumb here.  I have a fresh install of LAMP in a Virtual Box machine.  I am a Linux newbie, so I don't know much about what I'm doing, but I can usually figure stuff out eventually.  But I can't seem to access the Webmin.  I've attached a screenshot of the configuration console screen that lists the address links, but how do I get to them?  Hitting TAB or the arrow keys doesn't get me anywhere.  But I can go to advanced menu or toggle back and forth to the command prompt just fine.

Am I supposed to be able to use the mouse to click the links? (The mouse is neither visible nor usable on the linux screen).  Or do I need to type something directly into the command line?

Thanks--and sorry for being so dense.

Guest's picture

I'm going to take a guess

I'm going to take a guess here that my invisible mouse pointer is the problem.  Inside the linux window it is invisible.  Anybody have any suggestions as to how to fix that?

Liraz Siri's picture

Actually Webmin is a web

Actually Webmin is a web interface. It's not a local UI envirnoment like Windows. Point your browser to the URL shown in the main screen:

https://<your IP>:12321/
Guest's picture

Got it...

I didn't realize that by "browser" you meant a browser external to the virtual machine.  But I tried it, and it apparently works.   :)

That seems non-obvious enough to me that it should probably be in the documentation if it is not already.  I had assumed that I had to get to a browser inside the virtual machine.  But I guess not.

Thank you,

Guest's picture

And Console too

https://<your IP>:12320/

The above will provide an SSH session in a browser.

Andrei Rusu's picture

It does not work for me


i have tried to piont my browser to and an error connection occur. What is wrong?

Jeremy Davis's picture

Could be lots of things...

I suggest that you start a new thread detailing your environment, networking setup and exactly what you are trying to acheive...

Andrei Rusu's picture

Has been solved

I have solved the problem by setting the second network adapter available in VirtualBox which is set as Bridge. The first one was NAT. Then the second one allows me to connect via a local network. What really happens I don't understand very clear.

Jeremy Davis's picture

Unless you have need for NAT then I'd just use bridged

For an explanation of the different networking options read the TKL docs.

Andrei Rusu's picture


Merci, Jeremy,


you helped me a lot. Your link on virtual networking explained seems to suit me well.


with best wishes,


Jeremy Davis's picture

Good news! :)

Happy TKLing! :)

gordy.tech's picture

primary domain controller

downloaded the turnkey pdc iso and loaded on a dual core workstation I had sitting around.


Install went fine until it got to the advanced menu for network config - whether I choose DHCP or configure a static address, it doesnt accept the settings


so i exit the configuration, which takes me back to the CLI, but after logging in as root, i cannot get the webmin to launch

Jeremy Davis's picture

Probably best to start a new thread...

I suggest that you start a new thread, and I'll need details of what hardware you are using... At a guess it sounds like the drivers for your NIC aren't loading (which would be odd...). Or some other networking issue...?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)