ancara's picture

I have installed the Wordpress appliance and everthing is working fine accept for when I login into wordpress to upload a new theme I get the following error:

"The uploaded file could not be moved to /var/www/wordpress/wp-content/uploads/2012/03. "

Any ideas what could be causing this, as the rest of the wordpress front end seems to work fine 

Its only when i click on Theme under Appearence it suddenly takes ages to load (about two minutes)

and then  when I upload the new theme after about 3 minute the error presents itself.

I have checked the user rights in the /var/www/wordpress/wp-content/uploads/2012/03 directory and it all seems to be okay 




Jeremy Davis's picture

But sounds like you checked that... Just to be clear - it's owned by www-data:www-data? And has permissions set to 755?

ancara's picture

yes, I have double checked that. I am totally confused

Jeremy Davis's picture

The uploaded file could not be moved to /var/www/wordpress/wp-content/uploads/

...means that for your first content upload, such as images to place in a post or page, you may need to change permissions on /wp-content to 0777 temporarily to allow wordpress to create the uploads folder. After that you should be able to change it back to 0755.

And something else:

Switching off organise my uploads, and manually creating wp-content/uploads and setting just this folder to 777 has worked for me.

And finally - a php.ini tweak:

Not sure if any of thst will work for you? Seems like a pretty common WP problem over the last few years but also may have different causes...?

Be great if you can post back with what if anythung works.

If/when you chmod, don't forget to use the '-R' (recursive) switch.

It may be easier to just upload the theme direct to your server via SFTP?

Dennis Poon's picture

Wordpress was working fine a few days ago and today when I tried to upload a pic, I got that "The uploaded file could not be moved to /var/www/vhosts/"  I tried chmod 777 for the upload folder and I checked the rights of the folder in ssh and it seemed ok. 

I have already uncheck "organize ..,. by month" in the media settings.

pls help.

ancara's picture

How large is the file you are trying to upload? maybe you need to increase the limit in the php.ini file. 

Dennis Poon's picture

the file size was just 70k.  a jpeg file.

Add new comment