Stephan's picture

Hi guys.


Bambooinvoice server keeps trying to redirect me to a external site.

I do not have a Webserver or web address on my internal Network.

How do i setup Bamboo to point to a Internal domain instead of External.


Please help

Jeremy Davis's picture

If so then I suggest that you run it again and set it to the appliance IP (or a FQDN if you have a local DNS or add an entry to the hosts file of any PC you want to access it).


cd /usr/lib/inithooks/bin

and list the contents to find the name of the specific firstboot script (it'll probably be something like 'bamboo' or 'bamboo-invoice').


Assuming that it is bamboo


And re-enter your specific details. Be warned though, I'm not sure what will happen if you have data in there already (I imagine that it won't do anything bad, but perhaps...)

Voyager529's picture

I was working with this one as well and ended up making an entry in my hosts file to compensate for the compulsory domain name request.

I'd like to propose a feature request to either disable the requirement of a domain name being added during the installation, add an entry in Webmin somewhere that is highly visible and easy to modify in this regard, or ideally both.



Jeremy Davis's picture

I'm sure that the requirement for the server to have a domain name comes from Bamboo itself (and no doubt has some reason behind it - probably to do with security and avoiding XSS attack and/or SQL injection). I strongly suspect that the TKL firstboot script request is merely to fulfill that requirement of the upstream software. It's not something that the TKL devs would add just for the hell of it.

As for your idea of a Webmin page, that could be doable (and feel free to add it as a blueprint - see Help>>Development>>Blueprints) but I doubt it will be a priority for the TKL devs (especially when it can already be done pretty easily from the shell and it's really only something you only need to do once). Again you could request that the upstream devs add it to their todo list (either Webmin devs and/or Bamboo devs).

So that leaves you with needing to either edit your hosts file (as it sounds you've done) or you may be able to use the appliance IP instead of a domain name (but you'll obviously need to give your appliance a static IP and rerun the firstboot script as above). Other options are setting up a local DNS or using TKLDNS to use one of the free domain names.

Add new comment